Nissan 370Z Forum  

GT-R turbos on the VQ37

Would like to know what happen. What was the cause?

Go Back   Nissan 370Z Forum > Tech Area > Engine & Drivetrain

Like Tree758Likes

Reply
 
LinkBack Thread Tools Display Modes
Old 07-01-2017, 06:01 PM   #301 (permalink)
Now a Ronin Samurai
 
Rusty's Avatar
 
Join Date: Dec 2011
Location: Pennsyltucky
Age: 61
Posts: 8,273
Drives: 2011 Nismo GM 6M
Rep Power: 290529
Rusty has a reputation beyond reputeRusty has a reputation beyond reputeRusty has a reputation beyond reputeRusty has a reputation beyond reputeRusty has a reputation beyond reputeRusty has a reputation beyond reputeRusty has a reputation beyond reputeRusty has a reputation beyond reputeRusty has a reputation beyond reputeRusty has a reputation beyond reputeRusty has a reputation beyond repute
Talking

Would like to know what happen. What was the cause?
KngScottieV likes this.
__________________
Group C Driver, After Mods-334HP-279Tor. STD.|F.I. LTH|CBE/12" Resonators|Stillen Gen3|285/35-19, 345/30-19 Mich PSS on 9.5x19 and 12x19 ForgeLine Rims, Nismo RC Brake Ducts,|UpRev Tuned|http://www.the370z.com/members-370z-...o-journal.html
Rusty is offline   Reply With Quote
Old 07-02-2017, 12:47 AM   #302 (permalink)
A True Z Fanatic
 
Join Date: Apr 2013
Location: st. petersburg
Posts: 2,444
Drives: 09 nissan 370z Sp M6
Rep Power: 349
Elmo370z has a reputation beyond reputeElmo370z has a reputation beyond reputeElmo370z has a reputation beyond reputeElmo370z has a reputation beyond reputeElmo370z has a reputation beyond reputeElmo370z has a reputation beyond reputeElmo370z has a reputation beyond reputeElmo370z has a reputation beyond reputeElmo370z has a reputation beyond reputeElmo370z has a reputation beyond reputeElmo370z has a reputation beyond repute
Default

is it a 09?
Elmo370z is offline   Reply With Quote
Old 07-03-2017, 01:38 PM   #303 (permalink)
Broke
 
Join Date: Mar 2015
Location: West Bloomfields, MI
Age: 21
Posts: 345
Drives: '12 370Z, Corolla M
Rep Power: 21
husam2012 has a reputation beyond reputehusam2012 has a reputation beyond reputehusam2012 has a reputation beyond reputehusam2012 has a reputation beyond reputehusam2012 has a reputation beyond reputehusam2012 has a reputation beyond reputehusam2012 has a reputation beyond reputehusam2012 has a reputation beyond reputehusam2012 has a reputation beyond reputehusam2012 has a reputation beyond reputehusam2012 has a reputation beyond repute
Default

Opened the downpipes and dropped the pan.. not a single thing blocking the pickup tube and somehow the turbos still feel healthy with no resistance and no shaft play.



Any ideas why there was no oil pressure?



Sent from my iPhone using Tapatalk
Jpzman likes this.
__________________
http://gtrturboz.com/index.html
husam2012 is offline   Reply With Quote
Old 07-03-2017, 01:55 PM   #304 (permalink)
The370Z.com Sponsor
 
Join Date: Mar 2009
Location: Chicago
Posts: 3,228
Drives: 370
Rep Power: 727
phunk has a reputation beyond reputephunk has a reputation beyond reputephunk has a reputation beyond reputephunk has a reputation beyond reputephunk has a reputation beyond reputephunk has a reputation beyond reputephunk has a reputation beyond reputephunk has a reputation beyond reputephunk has a reputation beyond reputephunk has a reputation beyond reputephunk has a reputation beyond repute
Default

Oil galley gaskets are a common problem.

I dont know at what pressure the oil pressure switch closes. I will see if I can find it in the service manual. Perhaps you only had very low pressure rather than zero pressure. If the engine was only at idle and not being driven, it doesnt take much oil pressure to sustain. How much was the car driven or run with the light on? It sounds like it might be possible that you dodged a bullet. I have seen engines last for years of abuse after brief oil pressure mishaps.
__________________
Charles @ CJ Motorsports : Website | Facebook | Instagram | YouTube
Please follow our Instagram for our casual Z content.
370z - Twin Turbo, E85. 671rwhp @ 12 psi
2015 Mustang - Supercharged, E85. 815rwhp @ 13 psi
phunk is offline   Reply With Quote
Old 07-04-2017, 09:15 PM   #305 (permalink)
Broke
 
Join Date: Mar 2015
Location: West Bloomfields, MI
Age: 21
Posts: 345
Drives: '12 370Z, Corolla M
Rep Power: 21
husam2012 has a reputation beyond reputehusam2012 has a reputation beyond reputehusam2012 has a reputation beyond reputehusam2012 has a reputation beyond reputehusam2012 has a reputation beyond reputehusam2012 has a reputation beyond reputehusam2012 has a reputation beyond reputehusam2012 has a reputation beyond reputehusam2012 has a reputation beyond reputehusam2012 has a reputation beyond reputehusam2012 has a reputation beyond repute
Default

I actually hooked up a mechanical guage (cheap tester) and it didn't move at all which is what worried me.

I doubt it's the gaskets since that's a pre 2012 problem i believe. I also find it weird that the oil filter gets filled as soon as i crank it but the pressure gauge never shows anything. It's almost like the oil never comes back from the filter.

Only thing left to try is to remove the sandwich plate and try it with just the filter attached to the engine. I just have to order the shorter oil filter stud.
ScottM likes this.
husam2012 is offline   Reply With Quote
Old 07-05-2017, 11:56 AM   #306 (permalink)
Premium Member
 
Jayhovah's Avatar
 
Join Date: May 2013
Location: St. Pete, FL
Posts: 3,144
Drives: 520whp Fire Breather
Rep Power: 9945
Jayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond repute
Default

Oh man... Hope you find the issue.

A stupid question - your oil pan spacer came with a matching oil pickup spacer/gaskets, yes?

I'm not sold it would be the OEM oil cooler sandwich... since it hasn't changed for this install... Also, I have taken mine off... it is a pretty simple device and seems difficult to clog.

Hope you get to the bottom of this soon, i've got my fingers crossed the motor is still healthy.
__________________
2013 Gun Metallic Sport - Gamma V3 Twin Turbogized
First DIY Gamma V3 TT Install * Jayhovah's Gamma V3 TT Install Pic'Z and Vid'Z * DIY: Washer Reservoir for the Boosted
Quote:
Originally Posted by redondoaveb
You've got a twin turbo sound system, I think you met your audio goals.
Jayhovah is offline   Reply With Quote
Old 07-06-2017, 05:31 PM   #307 (permalink)
Broke
 
Join Date: Mar 2015
Location: West Bloomfields, MI
Age: 21
Posts: 345
Drives: '12 370Z, Corolla M
Rep Power: 21
husam2012 has a reputation beyond reputehusam2012 has a reputation beyond reputehusam2012 has a reputation beyond reputehusam2012 has a reputation beyond reputehusam2012 has a reputation beyond reputehusam2012 has a reputation beyond reputehusam2012 has a reputation beyond reputehusam2012 has a reputation beyond reputehusam2012 has a reputation beyond reputehusam2012 has a reputation beyond reputehusam2012 has a reputation beyond repute
Default

Good news! Finally found the problem. Somehow after removing the Mocal sandwich plate and getting the pre '12 stud, it works perfectly. Approx 100psi of oil pressure at idle.

The turbo return line was opened though haha so I have to clean up that mess tonight.

Crossing my fingers that the turbos and motor are still healthy


Sent from my iPhone using Tapatalk
__________________
http://gtrturboz.com/index.html
husam2012 is offline   Reply With Quote
Old 07-06-2017, 11:12 PM   #308 (permalink)
A True Z Fanatic
 
Join Date: Jun 2014
Location: Claxton, Ga
Posts: 2,665
Drives: 2013 Nismo 370z
Rep Power: 2865
Spooler has a reputation beyond reputeSpooler has a reputation beyond reputeSpooler has a reputation beyond reputeSpooler has a reputation beyond reputeSpooler has a reputation beyond reputeSpooler has a reputation beyond reputeSpooler has a reputation beyond reputeSpooler has a reputation beyond reputeSpooler has a reputation beyond reputeSpooler has a reputation beyond reputeSpooler has a reputation beyond repute
Default

Quote:
Originally Posted by husam2012 View Post
Good news! Finally found the problem. Somehow after removing the Mocal sandwich plate and getting the pre '12 stud, it works perfectly. Approx 100psi of oil pressure at idle.

The turbo return line was opened though haha so I have to clean up that mess tonight.

Crossing my fingers that the turbos and motor are still healthy


Sent from my iPhone using Tapatalk
Did you have the thermostatic Mocal plate? If so, that thing is bad.
husam2012 likes this.
Spooler is online now   Reply With Quote
Old 07-06-2017, 11:25 PM   #309 (permalink)
Broke
 
Join Date: Mar 2015
Location: West Bloomfields, MI
Age: 21
Posts: 345
Drives: '12 370Z, Corolla M
Rep Power: 21
husam2012 has a reputation beyond reputehusam2012 has a reputation beyond reputehusam2012 has a reputation beyond reputehusam2012 has a reputation beyond reputehusam2012 has a reputation beyond reputehusam2012 has a reputation beyond reputehusam2012 has a reputation beyond reputehusam2012 has a reputation beyond reputehusam2012 has a reputation beyond reputehusam2012 has a reputation beyond reputehusam2012 has a reputation beyond repute
Default

Quote:
Originally Posted by Spooler View Post
Did you have the thermostatic Mocal plate? If so, that thing is bad.


Yes that's the one I have. Unfortunately was with the car when I bought it.


Sent from my iPhone using Tapatalk
__________________
http://gtrturboz.com/index.html
husam2012 is offline   Reply With Quote
Old 07-07-2017, 09:09 AM   #310 (permalink)
I's the first...
 
jwick's Avatar
 
Join Date: Dec 2010
Location: Houston
Posts: 11,782
Drives: '10 G37 6MT
Rep Power: 669
jwick has a reputation beyond reputejwick has a reputation beyond reputejwick has a reputation beyond reputejwick has a reputation beyond reputejwick has a reputation beyond reputejwick has a reputation beyond reputejwick has a reputation beyond reputejwick has a reputation beyond reputejwick has a reputation beyond reputejwick has a reputation beyond reputejwick has a reputation beyond repute
Default

Quote:
Originally Posted by Spooler View Post
Did you have the thermostatic Mocal plate? If so, that thing is bad.

And what are you basing that on?
Wilson2608 likes this.
__________________
'10 G37T 6MT Graphite/Graphite - BP - G37T Build

jwick is offline   Reply With Quote
Old 07-07-2017, 01:37 PM   #311 (permalink)
A True Z Fanatic
 
Join Date: Jun 2014
Location: Claxton, Ga
Posts: 2,665
Drives: 2013 Nismo 370z
Rep Power: 2865
Spooler has a reputation beyond reputeSpooler has a reputation beyond reputeSpooler has a reputation beyond reputeSpooler has a reputation beyond reputeSpooler has a reputation beyond reputeSpooler has a reputation beyond reputeSpooler has a reputation beyond reputeSpooler has a reputation beyond reputeSpooler has a reputation beyond reputeSpooler has a reputation beyond reputeSpooler has a reputation beyond repute
Default

Quote:
Originally Posted by jwick View Post
And what are you basing that on?
It has a thermostat inside that opens up. Not sure why this happened. I would have to take it apart to see. I have one on my car and would like to know myself.
Spooler is online now   Reply With Quote
Old 07-07-2017, 02:02 PM   #312 (permalink)
Premium Member
 
Jayhovah's Avatar
 
Join Date: May 2013
Location: St. Pete, FL
Posts: 3,144
Drives: 520whp Fire Breather
Rep Power: 9945
Jayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond repute
Default

Quote:
Originally Posted by Spooler View Post
It has a thermostat inside that opens up. Not sure why this happened. I would have to take it apart to see. I have one on my car and would like to know myself.
I think the way you worded it - it sounded like you were saying the Mocal plate is bad in general, not that this particular one is bad. =)

I think tons of people are running Mocal plates and are happy with them... unlike the Mishimoto trash.
jwick and wideglideleon like this.
__________________
2013 Gun Metallic Sport - Gamma V3 Twin Turbogized
First DIY Gamma V3 TT Install * Jayhovah's Gamma V3 TT Install Pic'Z and Vid'Z * DIY: Washer Reservoir for the Boosted
Quote:
Originally Posted by redondoaveb
You've got a twin turbo sound system, I think you met your audio goals.
Jayhovah is offline   Reply With Quote
Old 07-07-2017, 02:03 PM   #313 (permalink)
Premium Member
 
Jayhovah's Avatar
 
Join Date: May 2013
Location: St. Pete, FL
Posts: 3,144
Drives: 520whp Fire Breather
Rep Power: 9945
Jayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond repute
Default

Quote:
Originally Posted by husam2012 View Post
good news! Finally found the problem. Somehow after removing the mocal sandwich plate and getting the pre '12 stud, it works perfectly. Approx 100psi of oil pressure at idle.

The turbo return line was opened though haha so i have to clean up that mess tonight.

Crossing my fingers that the turbos and motor are still healthy


sent from my iphone using tapatalk
victorious.
__________________
2013 Gun Metallic Sport - Gamma V3 Twin Turbogized
First DIY Gamma V3 TT Install * Jayhovah's Gamma V3 TT Install Pic'Z and Vid'Z * DIY: Washer Reservoir for the Boosted
Quote:
Originally Posted by redondoaveb
You've got a twin turbo sound system, I think you met your audio goals.
Jayhovah is offline   Reply With Quote
Old 07-07-2017, 03:53 PM   #314 (permalink)
A True Z Fanatic
 
Join Date: Jun 2014
Location: Claxton, Ga
Posts: 2,665
Drives: 2013 Nismo 370z
Rep Power: 2865
Spooler has a reputation beyond reputeSpooler has a reputation beyond reputeSpooler has a reputation beyond reputeSpooler has a reputation beyond reputeSpooler has a reputation beyond reputeSpooler has a reputation beyond reputeSpooler has a reputation beyond reputeSpooler has a reputation beyond reputeSpooler has a reputation beyond reputeSpooler has a reputation beyond reputeSpooler has a reputation beyond repute
Default

Quote:
Originally Posted by Jayhovah View Post
I think the way you worded it - it sounded like you were saying the Mocal plate is bad in general, not that this particular one is bad. =)

I think tons of people are running Mocal plates and are happy with them... unlike the Mishimoto trash.
Friends don't let friends buy Mishimoto.
jwick, Rusty and wideglideleon like this.
Spooler is online now   Reply With Quote
Old 07-07-2017, 03:59 PM   #315 (permalink)
Premium Member
 
Jayhovah's Avatar
 
Join Date: May 2013
Location: St. Pete, FL
Posts: 3,144
Drives: 520whp Fire Breather
Rep Power: 9945
Jayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond repute
Default

Quote:
Originally Posted by Spooler View Post
Friends don't let friends buy Mishimoto.
Someone needs to tell that to Trips and AK.
SgtGoldy and husam2012 like this.
__________________
2013 Gun Metallic Sport - Gamma V3 Twin Turbogized
First DIY Gamma V3 TT Install * Jayhovah's Gamma V3 TT Install Pic'Z and Vid'Z * DIY: Washer Reservoir for the Boosted
Quote:
Originally Posted by redondoaveb
You've got a twin turbo sound system, I think you met your audio goals.
Jayhovah is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[FOR SALE] Turbos NIZZING Parts for sale (Private Classifieds) 1 10-16-2016 10:03 PM
[FOR SALE] Turbos NIZZING Parts for sale (Private Classifieds) 0 08-11-2015 04:30 PM
[FOR SALE] Someone please buy my turbos! NIZZING Parts for sale (Private Classifieds) 3 11-12-2014 09:47 PM
EFR Turbos frydrce Forced Induction 34 08-30-2012 10:43 AM
somebody who knows a lot about turbos please help kevin1985912 Forced Induction 15 10-05-2010 12:00 PM


All times are GMT -5. The time now is 08:21 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 PL2