Nissan 370Z Forum  

service engine soon frustration

Hi All. Ok so this one is baffling me. 2010 vert with less than 50k on the clock. Shes an old gal but treated right. Have cold air intake and

Go Back   Nissan 370Z Forum > Other 370Z Models > Nissan 370Z Roadster (Convertible)

Like Tree18Likes

Reply
 
LinkBack Thread Tools Display Modes
Old 01-10-2018, 02:16 PM   #1 (permalink)
Base Member
 
Join Date: Nov 2015
Location: Orlando
Posts: 39
Drives: Nissan 370Z convert
Rep Power: 3
suzook is on a distinguished road
Default service engine soon frustration

Hi All. Ok so this one is baffling me. 2010 vert with less than 50k on the clock. Shes an old gal but treated right. Have cold air intake and exhaust as only upgrade. two times now the service engine light has com on and two replacement gas caps have solved the problem. Well its back again and after trying a third cap this time it wont go away. Any ideas? this is a second owner car and well maintained. hope someone can help
suzook is offline   Reply With Quote
Old 01-10-2018, 02:26 PM   #2 (permalink)
My member is elite
 
Chuck33079's Avatar
 
Join Date: Nov 2011
Location: Houston
Posts: 11,773
Drives: 2011 370ztt
Rep Power: 2159
Chuck33079 has a reputation beyond reputeChuck33079 has a reputation beyond reputeChuck33079 has a reputation beyond reputeChuck33079 has a reputation beyond reputeChuck33079 has a reputation beyond reputeChuck33079 has a reputation beyond reputeChuck33079 has a reputation beyond reputeChuck33079 has a reputation beyond reputeChuck33079 has a reputation beyond reputeChuck33079 has a reputation beyond reputeChuck33079 has a reputation beyond repute
Default

What's the code?
__________________
2011 MB Touring-Sport-6sp-Nav/GTM TT/FI TT TDX/JTran/Kosmic/Eibach/Hotchkis/SPC/CSF/RPS/SoThatsWhereAllMyMoneyWent
Chuck33079 is offline   Reply With Quote
Old 01-10-2018, 02:38 PM   #3 (permalink)
Premium Member
 
Jayhovah's Avatar
 
Join Date: May 2013
Location: St. Pete, FL
Posts: 3,353
Drives: 520whp Fire Breather
Rep Power: 13091
Jayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond repute
Default

Quote:
Originally Posted by Chuck33079 View Post
What's the code?
This. There are like a zillion things that could cause the light, you are flying blind if you don't pull the code. They will do it for free at the auto parts store... or you can buy a cheap blueooth OBDII dongle and pull the code with your phone.
SouthArk370Z likes this.
__________________
2013 Gun Metallic Sport - Gamma V3 Twin Turbogized
First DIY Gamma V3 TT Install * Jayhovah's Gamma V3 TT Install Pic'Z and Vid'Z * DIY: Washer Reservoir for the Boosted
Quote:
Originally Posted by redondoaveb
You've got a twin turbo sound system, I think you met your audio goals.
Jayhovah is offline   Reply With Quote
Old 01-10-2018, 03:02 PM   #4 (permalink)
Base Member
 
Join Date: Nov 2015
Location: Orlando
Posts: 39
Drives: Nissan 370Z convert
Rep Power: 3
suzook is on a distinguished road
Default

ah sorry forgot to get the code. Will stop in later and post back
wideglideleon likes this.
suzook is offline   Reply With Quote
Old 01-10-2018, 07:25 PM   #5 (permalink)
Base Member
 
SOUTHZZ's Avatar
 
Join Date: Jan 2014
Location: ALABAMA
Posts: 237
Drives: 09 NISSAN 370Z CS M6
Rep Power: 38
SOUTHZZ has a reputation beyond reputeSOUTHZZ has a reputation beyond reputeSOUTHZZ has a reputation beyond reputeSOUTHZZ has a reputation beyond reputeSOUTHZZ has a reputation beyond reputeSOUTHZZ has a reputation beyond reputeSOUTHZZ has a reputation beyond reputeSOUTHZZ has a reputation beyond reputeSOUTHZZ has a reputation beyond reputeSOUTHZZ has a reputation beyond reputeSOUTHZZ has a reputation beyond repute
Default

Without code info,its difficult to get a clear picture on what is causing the SES.
At times the SES can be a bit vague.
Noted you are in Florida. Temps not too bad even though lately has been om LOWS.

Is the car running OK?
May try to add some Sea Foam to the fuel.
Its very popular here.
I had a similar situation.It went away after adding.
Temps/Moisture?Gunk in the tank?
SOUTHZZ is offline   Reply With Quote
Old 01-10-2018, 07:45 PM   #6 (permalink)
Enthusiast Member
 
Zingston's Avatar
 
Join Date: May 2017
Location: Florida Gulf Coast
Posts: 408
Drives: like it's a rental.
Rep Power: 1305
Zingston has a reputation beyond reputeZingston has a reputation beyond reputeZingston has a reputation beyond reputeZingston has a reputation beyond reputeZingston has a reputation beyond reputeZingston has a reputation beyond reputeZingston has a reputation beyond reputeZingston has a reputation beyond reputeZingston has a reputation beyond reputeZingston has a reputation beyond reputeZingston has a reputation beyond repute
Default

Not saying it will definitely work in this situation, however, Seafoam has worked well for me in both 2 stroke and vehicular applications.
__________________
2015 370z PW Sport Tech (bring back the T-top!)
Zingston is offline   Reply With Quote
Old 01-11-2018, 12:04 PM   #7 (permalink)
Base Member
 
Join Date: Nov 2015
Location: Orlando
Posts: 39
Drives: Nissan 370Z convert
Rep Power: 3
suzook is on a distinguished road
Default

ok going to get the seafoam to try that first. Have not had a chance to get code yet but will this weekend. Car seems to run fine except it wont idle below 1000rmp

Is this what I want?
https://www.lowes.com/pd/Sea-Foam-16...YaAvFtEALw_wcB

do I pour the whole bottle in?
suzook is offline   Reply With Quote
Old 01-11-2018, 12:15 PM   #8 (permalink)
My member is elite
 
Chuck33079's Avatar
 
Join Date: Nov 2011
Location: Houston
Posts: 11,773
Drives: 2011 370ztt
Rep Power: 2159
Chuck33079 has a reputation beyond reputeChuck33079 has a reputation beyond reputeChuck33079 has a reputation beyond reputeChuck33079 has a reputation beyond reputeChuck33079 has a reputation beyond reputeChuck33079 has a reputation beyond reputeChuck33079 has a reputation beyond reputeChuck33079 has a reputation beyond reputeChuck33079 has a reputation beyond reputeChuck33079 has a reputation beyond reputeChuck33079 has a reputation beyond repute
Default

Don't seafoam the car, or do literally anything else, until you get the code. That's step one.
__________________
2011 MB Touring-Sport-6sp-Nav/GTM TT/FI TT TDX/JTran/Kosmic/Eibach/Hotchkis/SPC/CSF/RPS/SoThatsWhereAllMyMoneyWent
Chuck33079 is offline   Reply With Quote
Old 01-11-2018, 01:42 PM   #9 (permalink)
Enthusiast Member
 
Zingston's Avatar
 
Join Date: May 2017
Location: Florida Gulf Coast
Posts: 408
Drives: like it's a rental.
Rep Power: 1305
Zingston has a reputation beyond reputeZingston has a reputation beyond reputeZingston has a reputation beyond reputeZingston has a reputation beyond reputeZingston has a reputation beyond reputeZingston has a reputation beyond reputeZingston has a reputation beyond reputeZingston has a reputation beyond reputeZingston has a reputation beyond reputeZingston has a reputation beyond reputeZingston has a reputation beyond repute
Default

Quote:
Originally Posted by suzook View Post
ok going to get the seafoam to try that first. Have not had a chance to get code yet but will this weekend. Car seems to run fine except it wont idle below 1000rmp

Is this what I want?
https://www.lowes.com/pd/Sea-Foam-16...YaAvFtEALw_wcB

do I pour the whole bottle in?
Yes, that's it. I pour the whole bottle in when I fill up (couple times a year)
Like I said, not sure if it will address your issue, but I use it in all my vehicle (as a fuel additive, not an oil additive) and have had great results. Apparently there are others on this site that have a different opinion. So I guess do some research and decide what makes you most comfortable.

(Don't get me wrong here, this is by no means an alternative to figuring out the code)
__________________
2015 370z PW Sport Tech (bring back the T-top!)
Zingston is offline   Reply With Quote
Old 01-11-2018, 03:42 PM   #10 (permalink)
Premium Member
 
Join Date: Jan 2014
Location: Florida
Posts: 435
Drives: 09 black 370z MT
Rep Power: 5
Jimbo370 is on a distinguished road
Default

I am having the same problem. code PO900 THE MULTIPLE MISFIRES. I changed to HFC when it started and a light pulley.Then changed full agency exhaust and K&N drops and my mechanic keeps erasing the code. Now I added the exhaust extenders and it threw the same code in 40 degrees 2 days later. Changed spark plugs at 93k and wondering if its the COIL PACK. # 5 HAS 3 MISFIRES. FOLLOWING
Jimbo370 is offline   Reply With Quote
Old 01-11-2018, 03:50 PM   #11 (permalink)
My member is elite
 
Chuck33079's Avatar
 
Join Date: Nov 2011
Location: Houston
Posts: 11,773
Drives: 2011 370ztt
Rep Power: 2159
Chuck33079 has a reputation beyond reputeChuck33079 has a reputation beyond reputeChuck33079 has a reputation beyond reputeChuck33079 has a reputation beyond reputeChuck33079 has a reputation beyond reputeChuck33079 has a reputation beyond reputeChuck33079 has a reputation beyond reputeChuck33079 has a reputation beyond reputeChuck33079 has a reputation beyond reputeChuck33079 has a reputation beyond reputeChuck33079 has a reputation beyond repute
Default

Quote:
Originally Posted by Jimbo370 View Post
I am having the same problem. code PO900 THE MULTIPLE MISFIRES. I changed to HFC when it started and a light pulley.Then changed full agency exhaust and K&N drops and my mechanic keeps erasing the code. Now I added the exhaust extenders and it threw the same code in 40 degrees 2 days later. Changed spark plugs at 93k and wondering if its the COIL PACK. # 5 HAS 3 MISFIRES. FOLLOWING
Switch the coil pack with one of the other cylinders and see if the code follows it.
__________________
2011 MB Touring-Sport-6sp-Nav/GTM TT/FI TT TDX/JTran/Kosmic/Eibach/Hotchkis/SPC/CSF/RPS/SoThatsWhereAllMyMoneyWent
Chuck33079 is offline   Reply With Quote
Old 01-15-2018, 10:00 AM   #12 (permalink)
Base Member
 
Join Date: Nov 2015
Location: Orlando
Posts: 39
Drives: Nissan 370Z convert
Rep Power: 3
suzook is on a distinguished road
Default

Ok finally got my code P0300

Seems it could be a variety of things.

Also, with 50k on the clock, should I be changing out my KN air filters for the cold air intakes? Looks like you have to take the whole bloody front bumper off to get at them
suzook is offline   Reply With Quote
Old 01-15-2018, 10:26 AM   #13 (permalink)
Premium Member
 
Jayhovah's Avatar
 
Join Date: May 2013
Location: St. Pete, FL
Posts: 3,353
Drives: 520whp Fire Breather
Rep Power: 13091
Jayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond repute
Default

Quote:
Originally Posted by suzook View Post
Ok finally got my code P0300

Seems it could be a variety of things.

Also, with 50k on the clock, should I be changing out my KN air filters for the cold air intakes? Looks like you have to take the whole bloody front bumper off to get at them
P0300 seems to have a limitless number possibilities, but they all seem to be vibration related. I have read some folks have gotten it fixed with clutch/flywheel changes. I've had it pop up on me a twice in a little over two years and both times I just cleared the code and moved on with my life.

If I were you, I would buy a cheap bluetooth code reader (~$10) and just clear it and wait to see how often it comes back.

Keep in mind - at this point you don't know if this is the same code you were throwing before. Clear it and wait to see what comes up... if the same code keeps reappearing then you will at least have a starting point for your search.
__________________
2013 Gun Metallic Sport - Gamma V3 Twin Turbogized
First DIY Gamma V3 TT Install * Jayhovah's Gamma V3 TT Install Pic'Z and Vid'Z * DIY: Washer Reservoir for the Boosted
Quote:
Originally Posted by redondoaveb
You've got a twin turbo sound system, I think you met your audio goals.
Jayhovah is offline   Reply With Quote
Old 01-15-2018, 10:35 AM   #14 (permalink)
Base Member
 
Join Date: Nov 2015
Location: Orlando
Posts: 39
Drives: Nissan 370Z convert
Rep Power: 3
suzook is on a distinguished road
Default

ok got it. All I know is that when this comes on the car which previously idled at 500 now wont settle down past 1000. I had replaced the fuel cap before and that did the trick but this time no go. suggestions for a BT reader?

Also, any comment on the filters

Thank you all
suzook is offline   Reply With Quote
Old 01-15-2018, 10:46 AM   #15 (permalink)
Enthusiast Member
 
Join Date: Dec 2016
Location: Nebraska
Posts: 254
Drives: 2010 Nissan 370z 6MT
Rep Power: 2
Zatanna Z is on a distinguished road
Default

Quote:
Originally Posted by suzook View Post
ok got it. All I know is that when this comes on the car which previously idled at 500 now wont settle down past 1000. I had replaced the fuel cap before and that did the trick but this time no go. suggestions for a BT reader?

Also, any comment on the filters

Thank you all
Do you have a stillen g3 intake? If so are the filters dry or oiled? And if so all you need to do is take them off the tube and clean them. Taking the front bumper off is really easy. There is a DIY on this forum. Also I have this code coming up off and on and now I just ignore it. I'm pretty sure it has to do with vibration b/c my car drives fine.
Zatanna Z is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Service engine soon... WELL ZED Engine & Drivetrain 13 03-20-2017 11:25 AM
Service Engine Soon Zatanna Z Engine & Drivetrain 6 02-05-2017 05:11 AM
Service Engine Soon The BlueMax Nissan 370Z General Discussions 15 01-22-2015 08:18 PM
Service Engine Soon Keithbeeesh Nissan 370Z General Discussions 23 11-17-2014 09:05 AM
service engine soon... ddvette9 Nissan 370Z General Discussions 17 07-15-2010 09:00 AM


All times are GMT -5. The time now is 10:56 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 PL2