Nissan 370Z Forum  

Circuit sports direct ignition system dis amplifier

I've read about this on here and was looking to buy. What's up with all the owners who have bought and installed. Even with no dyno numbers, how is the

Go Back   Nissan 370Z Forum > Nissan 370Z Tech Area > Engine & Drivetrain > Tuning

Like Tree3Likes

Reply
 
LinkBack Thread Tools Display Modes
Old 02-18-2013, 06:10 AM   #16 (permalink)
Enthusiast Member
 
JC671's Avatar
 
Join Date: Feb 2011
Location: Guam
Posts: 451
Drives: Toretto around
Rep Power: 11
JC671 is on a distinguished road
Default Bump from the dead

I've read about this on here and was looking to buy. What's up with all the owners who have bought and installed.

Even with no dyno numbers, how is the butt dyno? Does it rev faster? Does it accelerate faster?

Bump for feedback from actual owners who are running it currently.
JC671 is offline   Reply With Quote
Old 02-19-2013, 05:40 PM   #17 (permalink)
Track Member
 
AlexRaymond19's Avatar
 
Join Date: Jun 2011
Location: Maine
Posts: 771
Drives: 2010 Nissan 370z
Rep Power: 12
AlexRaymond19 is on a distinguished road
Default

I am interested too... Results?!
__________________
2010 370Z Touring MT | Stillen | Motordyne | Momentum| Z1 | Fast Intentions | Advant Garde | RE11 | Swift | SPC | Quaife | Whiteline | Evo R | 322RWHP 259ft-lb Mustang
AlexRaymond19 is offline   Reply With Quote
Old 03-12-2013, 04:44 AM   #18 (permalink)
Banned
 
Join Date: Apr 2012
Location: Canoga
Posts: 505
Drives: Myself crazy
Rep Power: 0
NitrousZ34 is on a distinguished road
Default

updates?
NitrousZ34 is offline   Reply With Quote
Old 03-12-2013, 07:43 AM   #19 (permalink)
Enthusiast Member
 
JC671's Avatar
 
Join Date: Feb 2011
Location: Guam
Posts: 451
Drives: Toretto around
Rep Power: 11
JC671 is on a distinguished road
Default

Quote:
Originally Posted by NitrousZ34 View Post
updates?
Either owners aren't chiming in or this sucks...

Please if you have them post your experience.
JC671 is offline   Reply With Quote
Old 04-08-2013, 12:06 AM   #20 (permalink)
Base Member
 
Join Date: Jun 2012
Location: Califas
Posts: 15
Drives: Black 370Z
Rep Power: 10
ebb559 is on a distinguished road
Default

Had it installed last month AFTER my dyno unfortunetly. My opinion on it from my experience alone.

- It came with no instructions of any kind but then again it was rather self explanatory. Would of been great installing it knowing I was doing it right... right?

- After a month I've noticed my Tuned maps would reset and my S-Drive would be off when I'd turn the car on the next morning. Confused and shrugging it off... thinking it wasn't anything to worry so much about. I got a Check Engine Light after a couple more days after. Reviewing the code It came up with:

P0603 Internal Control Module Keep Alive Memory (KAM) Error.

Talked to my tuner about what could have caused this. I was recommended to remove Temporally the CS-DIS and see how it runs and behaves.

After Experience daily issues with reset Maps and Service Engine Lights popping up, I no longer have this issue with it turned off(battery connection severed).

I did email CS about said problem, curiously awaiting a response from their team.

Did a google screen if anyone else had this similar problem... seems like I may be the first to post it... again seems.
Legz likes this.
ebb559 is offline   Reply With Quote
Old 04-08-2013, 01:47 AM   #21 (permalink)
Enthusiast Member
 
JC671's Avatar
 
Join Date: Feb 2011
Location: Guam
Posts: 451
Drives: Toretto around
Rep Power: 11
JC671 is on a distinguished road
Default

Quote:
Originally Posted by ebb559 View Post
Had it installed last month AFTER my dyno unfortunetly. My opinion on it from my experience alone.

- It came with no instructions of any kind but then again it was rather self explanatory. Would of been great installing it knowing I was doing it right... right?

- After a month I've noticed my Tuned maps would reset and my S-Drive would be off when I'd turn the car on the next morning. Confused and shrugging it off... thinking it wasn't anything to worry so much about. I got a Check Engine Light after a couple more days after. Reviewing the code It came up with:

P0603 Internal Control Module Keep Alive Memory (KAM) Error.

Talked to my tuner about what could have caused this. I was recommended to remove Temporally the CS-DIS and see how it runs and behaves.

After Experience daily issues with reset Maps and Service Engine Lights popping up, I no longer have this issue with it turned off(battery connection severed).

I did email CS about said problem, curiously awaiting a response from their team.

Did a google screen if anyone else had this similar problem... seems like I may be the first to post it... again seems.

Interesting and thank you for sharing your experience. Please do keep us updated.
__________________

A special "Thank You" to the Fast Intentions Crew!
"Fueled By Passion"
JC671 is offline   Reply With Quote
Old 04-10-2013, 02:03 AM   #22 (permalink)
Base Member
 
Join Date: Jun 2012
Location: Califas
Posts: 15
Drives: Black 370Z
Rep Power: 10
ebb559 is on a distinguished road
Default

Further digging around and feedback states that it could be a battery issue. Not enough power I suppose to support the DIS which in turn is setting off codes.

I did order a Yellow Top Optima Battery(as it was recommended). I do run a full system audio and with the DIS activated, it would make sense to get something with more umph. I feel most certainly this was/is the issue as my current battery is 3 years old and stock.

Will continue to update status for anyone still interested.
Legz likes this.
ebb559 is offline   Reply With Quote
Old 04-10-2013, 04:01 AM   #23 (permalink)
Enthusiast Member
 
JC671's Avatar
 
Join Date: Feb 2011
Location: Guam
Posts: 451
Drives: Toretto around
Rep Power: 11
JC671 is on a distinguished road
Thumbs up

Quote:
Originally Posted by ebb559 View Post
Further digging around and feedback states that it could be a battery issue. Not enough power I suppose to support the DIS which in turn is setting off codes.

I did order a Yellow Top Optima Battery(as it was recommended). I do run a full system audio and with the DIS activated, it would make sense to get something with more umph. I feel most certainly this was/is the issue as my current battery is 3 years old and stock.

Will continue to update status for anyone still interested.
Thanks.. Awaiting update... Did you feel any difference after you installed this? Did you feel like it revs faster? Any type of feedback other than "I think it works" would help. Just don't want to throw away cash that's all.
__________________

A special "Thank You" to the Fast Intentions Crew!
"Fueled By Passion"
JC671 is offline   Reply With Quote
Old 04-10-2013, 12:14 PM   #24 (permalink)
Premium Member
 
SS_Firehawk's Avatar
 
Join Date: Oct 2011
Location: Tampa
Posts: 4,122
Drives: 13' Magma Red Nismo
Rep Power: 7275
SS_Firehawk has a reputation beyond reputeSS_Firehawk has a reputation beyond reputeSS_Firehawk has a reputation beyond reputeSS_Firehawk has a reputation beyond reputeSS_Firehawk has a reputation beyond reputeSS_Firehawk has a reputation beyond reputeSS_Firehawk has a reputation beyond reputeSS_Firehawk has a reputation beyond reputeSS_Firehawk has a reputation beyond reputeSS_Firehawk has a reputation beyond reputeSS_Firehawk has a reputation beyond repute
Default

The car has direct ignition and it's new, I doubt it does much, besides throws codes
Jordo! likes this.
__________________
Old Car:GTM TSC'd 550whp / 410lbft tq @ 11.88PSI
New Car: Under Construction

SS_Firehawk is offline   Reply With Quote
Old 04-10-2013, 01:03 PM   #25 (permalink)
Base Member
 
Join Date: Jun 2012
Location: Califas
Posts: 15
Drives: Black 370Z
Rep Power: 10
ebb559 is on a distinguished road
Default

While I had it on, it was hard to really tell the difference. Because of the extra surge this device provides, I believe this would most benefit bigger injectors vehicles ie; Turbo/supercharged to give a complete clean burn per spark. Hence why the partial gains from a *turbo* 240sx.

I bought it for the reassurance that each cylinder is receiving a clean burn on strike. I do plan to upgrade the car to boost in the future. The gains after boost is where this device would be most desirable. My opinion.
ebb559 is offline   Reply With Quote
Old 04-24-2013, 02:42 AM   #26 (permalink)
Base Member
 
Join Date: Jun 2012
Location: Califas
Posts: 15
Drives: Black 370Z
Rep Power: 10
ebb559 is on a distinguished road
Default

Verdict:
After installing a Yellow Top Optima battery as suggested by a tuner. I get the same error codes and faulty results. I also sent 2 emails to the company with ZERO response to the issue or any service of sorts.

It may work for other cars, but I do believe this gets 2 thumps down for the 370z.

No Service, No working product = bad deal. Be weary when purchasing.
ebb559 is offline   Reply With Quote
Old 04-24-2013, 02:48 AM   #27 (permalink)
A True Z Fanatic
 
NeverBoneStck's Avatar
 
Join Date: Oct 2009
Location: Beaverton, Or
Posts: 1,102
Drives: 2008 G37 S
Rep Power: 15
NeverBoneStck is on a distinguished road
Default

I have had this on my car for a long time now with zero issues ... I wonder why you are getting the code ??
__________________
Juiced! That is all you need to know !!
NeverBoneStck is offline   Reply With Quote
Old 04-24-2013, 03:04 AM   #28 (permalink)
Base Member
 
Join Date: Jun 2012
Location: Califas
Posts: 15
Drives: Black 370Z
Rep Power: 10
ebb559 is on a distinguished road
Default

Exactly what I would like to know.
ebb559 is offline   Reply With Quote
Old 04-24-2013, 03:05 AM   #29 (permalink)
Premium Member Bitches
 
DEpointfive0's Avatar
 
Join Date: Jan 2012
Location: SoCal
Posts: 14,825
Drives: a lot
Rep Power: 17148
DEpointfive0 has a reputation beyond reputeDEpointfive0 has a reputation beyond reputeDEpointfive0 has a reputation beyond reputeDEpointfive0 has a reputation beyond reputeDEpointfive0 has a reputation beyond reputeDEpointfive0 has a reputation beyond reputeDEpointfive0 has a reputation beyond reputeDEpointfive0 has a reputation beyond reputeDEpointfive0 has a reputation beyond reputeDEpointfive0 has a reputation beyond reputeDEpointfive0 has a reputation beyond repute
Default

Quote:
Originally Posted by NeverBoneStck View Post
I have had this on my car for a long time now with zero issues ... I wonder why you are getting the code ??
What were your thoughts on it?
__________________
Do YOU want to know what/where I got my username from?
( Click to show/hide )
DEpointfive0 is offline   Reply With Quote
Old 04-24-2013, 03:17 AM   #30 (permalink)
Enthusiast Member
 
JC671's Avatar
 
Join Date: Feb 2011
Location: Guam
Posts: 451
Drives: Toretto around
Rep Power: 11
JC671 is on a distinguished road
Default

Quote:
Originally Posted by NeverBoneStck View Post
I have had this on my car for a long time now with zero issues ... I wonder why you are getting the code ??
Care to chime in with your review?
__________________

A special "Thank You" to the Fast Intentions Crew!
"Fueled By Passion"
JC671 is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Choosing an amplifier 2011 Nismo#91 Audio & Video 24 09-12-2011 08:08 AM
MSD ignition control. someday Tuning 2 08-13-2011 11:55 AM
subwoofer & amplifier JayYoon Audio & Video 16 08-15-2010 03:52 AM
Bridging The amplifier HT Rambler Audio & Video 8 04-22-2010 02:05 PM
Amplifier Question... zinistr Audio & Video 10 02-21-2010 06:57 PM


All times are GMT -5. The time now is 04:45 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 PL2