Nissan 370Z Forum  

Help! Engine stops in drive or rear mode

Hey guys, I am from germany. Sorry for my bad english my 2009 370Z 7AT makes me problems. Sometimes if I stop the car in drive or rear mode, the

Go Back   Nissan 370Z Forum > Tech Area > Engine & Drivetrain

Like Tree7Likes

Reply
 
LinkBack Thread Tools Display Modes
Old 09-10-2019, 12:40 PM   #1 (permalink)
Base Member
 
MadK11's Avatar
 
Join Date: Feb 2013
Location: Germany
Posts: 14
Drives: 10 Nissan 370Z w Aut
Rep Power: 20917
MadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond repute
Default Help! Engine stops in drive or rear mode

Hey guys,

I am from germany. Sorry for my bad english

my 2009 370Z 7AT makes me problems. Sometimes if I stop the car in drive or rear mode, the engine stops. It feels like, a clutch does not open.

There is a p1585 G-sensor code in the transmission control module.

I changed the tranny fluid and flushed the hole system. For the next 100km was everything allright. But now ii is worse then before.

Has anybody got an idea?
MadK11 is offline   Reply With Quote
Old 09-10-2019, 12:47 PM   #2 (permalink)
Rated Z
 
JARblue's Avatar
 
Join Date: Mar 2011
Location: Austin, TX
Age: 38
Posts: 30,050
Drives: 2011 370Z Sport MT
Rep Power: 2684423
JARblue has a reputation beyond reputeJARblue has a reputation beyond reputeJARblue has a reputation beyond reputeJARblue has a reputation beyond reputeJARblue has a reputation beyond reputeJARblue has a reputation beyond reputeJARblue has a reputation beyond reputeJARblue has a reputation beyond reputeJARblue has a reputation beyond reputeJARblue has a reputation beyond reputeJARblue has a reputation beyond repute
Default

Like the car dies completely?

Did you flush the AT transmission fluid using the correct steps per the factory service manual? If you simply drain and refill, it will not be at the correct fill level when the transmission warms up.


A quick google search appears to indicate the error code is a Throttle Control Unit malfunction.
__________________

2011 370Z 6MT Sport Gun Metallic | ARC | CJM | Ecutek | FI | RJM | R2C | SPL | Stillen | TWM | Z1 | ZSpeed |

Last edited by JARblue; 09-10-2019 at 12:50 PM.
JARblue is offline   Reply With Quote
Old 09-10-2019, 01:00 PM   #3 (permalink)
Base Member
 
MadK11's Avatar
 
Join Date: Feb 2013
Location: Germany
Posts: 14
Drives: 10 Nissan 370Z w Aut
Rep Power: 20917
MadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond repute
Default

I dont use the original manual, but I used over 15 liters of gnissan tranny fluid to flush the hole system. I filled the tranny up, start the engine, until it has about 35 degrees Celcius. I think this is 95 degrees fahrenheit, change every gear P, R, N, D for 10 seconds and then I oben the screw until the fluid drops in short frequencies.

What do you mean. Was it correct?
MadK11 is offline   Reply With Quote
Old 09-10-2019, 01:05 PM   #4 (permalink)
Base Member
 
MadK11's Avatar
 
Join Date: Feb 2013
Location: Germany
Posts: 14
Drives: 10 Nissan 370Z w Aut
Rep Power: 20917
MadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond repute
Default

I also checked the realtime data of the g-sensor.
When I stop at a flate place, it shows about 0,.. degrees. When I drive it works realistc, I think. When I park at a pitch or a slope, the data is realistic as well.
MadK11 is offline   Reply With Quote
Old 09-10-2019, 02:28 PM   #5 (permalink)
Rated Z
 
JARblue's Avatar
 
Join Date: Mar 2011
Location: Austin, TX
Age: 38
Posts: 30,050
Drives: 2011 370Z Sport MT
Rep Power: 2684423
JARblue has a reputation beyond reputeJARblue has a reputation beyond reputeJARblue has a reputation beyond reputeJARblue has a reputation beyond reputeJARblue has a reputation beyond reputeJARblue has a reputation beyond reputeJARblue has a reputation beyond reputeJARblue has a reputation beyond reputeJARblue has a reputation beyond reputeJARblue has a reputation beyond reputeJARblue has a reputation beyond repute
Default

Probably good enough on the flush. The key is to get the fluid warm so you can check the fill level properly.
__________________

2011 370Z 6MT Sport Gun Metallic | ARC | CJM | Ecutek | FI | RJM | R2C | SPL | Stillen | TWM | Z1 | ZSpeed |
JARblue is offline   Reply With Quote
Old 09-10-2019, 04:35 PM   #6 (permalink)
A True Z Fanatic
 
SouthArk370Z's Avatar
 
Join Date: Nov 2010
Location: South Arkansas
Posts: 7,560
Drives: 2014 Challenger
Rep Power: 45678
SouthArk370Z has a reputation beyond reputeSouthArk370Z has a reputation beyond reputeSouthArk370Z has a reputation beyond reputeSouthArk370Z has a reputation beyond reputeSouthArk370Z has a reputation beyond reputeSouthArk370Z has a reputation beyond reputeSouthArk370Z has a reputation beyond reputeSouthArk370Z has a reputation beyond reputeSouthArk370Z has a reputation beyond reputeSouthArk370Z has a reputation beyond reputeSouthArk370Z has a reputation beyond repute
Default

Quote:
Originally Posted by MadK11 View Post
... Sometimes if I stop the car in drive or rear mode, the engine stops. It feels like, a clutch does not open. ...
Sounds like the torque convertor lockup is not unlocking.
MadK11, Asus_ and elhombre like this.
__________________
Steering Lock Links - Search The370Z Bookmarklet - FSM @ NICOclub
Mankind has progressed past the need for war but we haven't evolved that far. - NachoMahma
SouthArk370Z is offline   Reply With Quote
Old 09-10-2019, 08:17 PM   #7 (permalink)
RWT
Base Member
 
Join Date: Mar 2019
Location: SE Georgia
Posts: 10
Drives: 13 Nissan 370Z T
Rep Power: 1
RWT is on a distinguished road
Default

Quote:
Originally Posted by SouthArk370Z View Post
Sounds like the torque convertor lockup is not unlocking.
This was my first thought also.
MadK11 likes this.
__________________
RWT
2013 370Z Touring/Sport, Magnetic Black, 6MT, Stillen Gen 3 intake, Ark GRiP exhaust.
RWT is offline   Reply With Quote
Old 09-11-2019, 03:33 AM   #8 (permalink)
Base Member
 
MadK11's Avatar
 
Join Date: Feb 2013
Location: Germany
Posts: 14
Drives: 10 Nissan 370Z w Aut
Rep Power: 20917
MadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond repute
Default

This is possible, but how can I find out? Suppose it were, what would be the cause? Maybe the Transmission Valve Body?

And why I have the CODE P1585 G-Sensor in the tranny module?

Has anybody out there the same problems?
MadK11 is offline   Reply With Quote
Old 09-11-2019, 03:13 PM   #9 (permalink)
Base Member
 
Join Date: Aug 2010
Location: MD
Posts: 64
Drives: 09 tour/sprt wht 7A
Rep Power: 396
CrunchyCajun has a reputation beyond reputeCrunchyCajun has a reputation beyond reputeCrunchyCajun has a reputation beyond reputeCrunchyCajun has a reputation beyond reputeCrunchyCajun has a reputation beyond reputeCrunchyCajun has a reputation beyond reputeCrunchyCajun has a reputation beyond reputeCrunchyCajun has a reputation beyond reputeCrunchyCajun has a reputation beyond reputeCrunchyCajun has a reputation beyond reputeCrunchyCajun has a reputation beyond repute
Default

This is EXACTLY what happened with my 7AT at 48k miles. Paperwork said "torque convertor. locked up."

The car was under warranty and Nissan replaced the entire transmission. However, the torque convertor can be changed and there is at least 1 modified one that sounds like it should handle anything thrown at it.

https://www.levelten.com/370_TORQUE_...-converter.htm
MadK11 and Asus_ like this.

Last edited by CrunchyCajun; 09-12-2019 at 03:50 AM.
CrunchyCajun is offline   Reply With Quote
Old 09-12-2019, 05:52 AM   #10 (permalink)
Base Member
 
MadK11's Avatar
 
Join Date: Feb 2013
Location: Germany
Posts: 14
Drives: 10 Nissan 370Z w Aut
Rep Power: 20917
MadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond repute
Default

You lucky guy. My Z has no warranty

Thank you for the link, but the question is, is the torque converter my problem, or the valve body, because the torque converter is controlled by the valvebody?
If the torque converter clutch solenoid doesnt work properly, then it is the same effect.

Has anybody a wiring diagram for the solenoid. I will try to cut the wire to the torque converter clutch solenoid. Then I can be sure which part doesnt work right.
MadK11 is offline   Reply With Quote
Old 09-12-2019, 07:14 AM   #11 (permalink)
A True Z Fanatic
 
SouthArk370Z's Avatar
 
Join Date: Nov 2010
Location: South Arkansas
Posts: 7,560
Drives: 2014 Challenger
Rep Power: 45678
SouthArk370Z has a reputation beyond reputeSouthArk370Z has a reputation beyond reputeSouthArk370Z has a reputation beyond reputeSouthArk370Z has a reputation beyond reputeSouthArk370Z has a reputation beyond reputeSouthArk370Z has a reputation beyond reputeSouthArk370Z has a reputation beyond reputeSouthArk370Z has a reputation beyond reputeSouthArk370Z has a reputation beyond reputeSouthArk370Z has a reputation beyond reputeSouthArk370Z has a reputation beyond repute
Default

Quote:
Originally Posted by MadK11 View Post
... Has anybody a wiring diagram for the solenoid. I will try to cut the wire to the torque converter clutch solenoid. Then I can be sure which part doesnt work right.
Check the FSM. Link in sig.
MadK11 likes this.
__________________
Steering Lock Links - Search The370Z Bookmarklet - FSM @ NICOclub
Mankind has progressed past the need for war but we haven't evolved that far. - NachoMahma
SouthArk370Z is offline   Reply With Quote
Old 09-12-2019, 02:17 PM   #12 (permalink)
Base Member
 
MadK11's Avatar
 
Join Date: Feb 2013
Location: Germany
Posts: 14
Drives: 10 Nissan 370Z w Aut
Rep Power: 20917
MadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond repute
Default

Nice,

I will try as soon as possible
MadK11 is offline   Reply With Quote
Old 09-12-2019, 03:10 PM   #13 (permalink)
A True Z Fanatic
 
Join Date: Jun 2014
Location: Claxton, Ga
Posts: 6,144
Drives: 2013 Nismo 370z
Rep Power: 467474
Spooler has a reputation beyond reputeSpooler has a reputation beyond reputeSpooler has a reputation beyond reputeSpooler has a reputation beyond reputeSpooler has a reputation beyond reputeSpooler has a reputation beyond reputeSpooler has a reputation beyond reputeSpooler has a reputation beyond reputeSpooler has a reputation beyond reputeSpooler has a reputation beyond reputeSpooler has a reputation beyond repute
Default

Quote:
Originally Posted by MadK11 View Post
You lucky guy. My Z has no warranty

Thank you for the link, but the question is, is the torque converter my problem, or the valve body, because the torque converter is controlled by the valvebody?
If the torque converter clutch solenoid doesnt work properly, then it is the same effect.

Has anybody a wiring diagram for the solenoid. I will try to cut the wire to the torque converter clutch solenoid. Then I can be sure which part doesnt work right.
If when you try to stop and the car keeps going forward until you stall it, the TC broke a sprag not allowing it to unlock. Dodge diesel trucks would do this but they have an anti-stall feature making the truck just push right on through the brakes. Talk about a crap the pants moment.
Spooler is offline   Reply With Quote
Old 09-16-2019, 05:10 AM   #14 (permalink)
Base Member
 
MadK11's Avatar
 
Join Date: Feb 2013
Location: Germany
Posts: 14
Drives: 10 Nissan 370Z w Aut
Rep Power: 20917
MadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond reputeMadK11 has a reputation beyond repute
Default

Ok, but it is not every time. Some days everything works good, another day the problem almost always appears. That irritates me a little
MadK11 is offline   Reply With Quote
Old 09-16-2019, 07:05 PM   #15 (permalink)
Premium Member
 
Join Date: Jun 2016
Location: Massachusetts
Posts: 214
Drives: 07 350z Nismo #0363
Rep Power: 4
NissanTracker is on a distinguished road
Default

Servus! Viel Glück. aus Amerika ��
NissanTracker is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Limp mode after engine swap Alaadinz Engine & Drivetrain 4 06-13-2019 11:24 PM
370Z Nismo, engine stops and won’t start Morfiy Nissan 370Z Warranty / Scheduled Maintenance / Servicing / Repairs 3 05-01-2019 11:45 AM
Limp Mode after Steam engine clean wtolbert Engine & Drivetrain 4 07-20-2016 12:47 AM
Service Engine Soon + Limp Mode Terrace Nissan 370Z General Discussions 15 02-06-2014 05:11 PM
Engine revving unnecessarily high/ S-mode malfunction MileHighZ Nissan 370Z Warranty / Scheduled Maintenance / Servicing / Repairs 7 06-04-2011 11:03 PM


All times are GMT -5. The time now is 08:16 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 PL2