Nissan 370Z Forum  

How to setup crossover frequencies etc

Hello all, I have a set of DB6501s, pioneer avh x4800bs HU with a 500w mono amp withe two 12" subs. After plugging everything in, the speakers were really crappy

Go Back   Nissan 370Z Forum > Nissan 370Z Tech Area > Audio & Video

Like Tree3Likes

Reply
 
LinkBack Thread Tools Display Modes
Old 08-03-2016, 04:48 PM   #1 (permalink)
Base Member
 
Join Date: Jul 2016
Location: Chicago IL, San jose CA
Posts: 99
Drives: 16 base coupe
Rep Power: 5
Djvalerio921 is on a distinguished road
Default How to setup crossover frequencies etc

Hello all, I have a set of DB6501s, pioneer avh x4800bs HU with a 500w mono amp withe two 12" subs. After plugging everything in, the speakers were really crappy sounding. It has a crossover menu on it, but not sure on how to adjust the frequencies and lpf/hpf. Could the mid woofer not be pushing any bass because I don't have an amp for it?
Djvalerio921 is offline   Reply With Quote
Old 08-03-2016, 06:35 PM   #2 (permalink)
A True Z Fanatic
 
RonRizz's Avatar
 
Join Date: Aug 2011
Location: Pine grove, Pa
Posts: 2,133
Drives: 2 feet, 3 pedals
Rep Power: 6771
RonRizz has a reputation beyond reputeRonRizz has a reputation beyond reputeRonRizz has a reputation beyond reputeRonRizz has a reputation beyond reputeRonRizz has a reputation beyond reputeRonRizz has a reputation beyond reputeRonRizz has a reputation beyond reputeRonRizz has a reputation beyond reputeRonRizz has a reputation beyond reputeRonRizz has a reputation beyond reputeRonRizz has a reputation beyond repute
Default

Subwoofer low pass 80hz Components high pass 80hz give that a shot.
Solid370z likes this.
__________________
P99rs Head Unit--- Amps- 2 Pioneer Prs800d --- Zapco ST1000MX---Zapco ST-4XSQ---- SI BM mk5 Subs---SI TM65v2 Midbass--- SI M3 mids--- SI M25 xbl2 tweeters ----- 2016 MECA street class 3rd place at world finals
RonRizz is offline   Reply With Quote
Old 08-04-2016, 06:08 PM   #3 (permalink)
Base Member
 
Join Date: Jul 2016
Location: Chicago IL, San jose CA
Posts: 99
Drives: 16 base coupe
Rep Power: 5
Djvalerio921 is on a distinguished road
Default

This is what I have it set to right now.. Still feel like I'm not getting the polks potential
Attached Images
File Type: jpeg image.jpeg (268.9 KB, 38 views)
Djvalerio921 is offline   Reply With Quote
Old 08-04-2016, 06:09 PM   #4 (permalink)
Base Member
 
Join Date: Jul 2016
Location: Chicago IL, San jose CA
Posts: 99
Drives: 16 base coupe
Rep Power: 5
Djvalerio921 is on a distinguished road
Default

I don't know how to post multiple images because I'm on my phone lol
Attached Images
File Type: jpeg image.jpeg (279.6 KB, 15 views)
Djvalerio921 is offline   Reply With Quote
Old 08-04-2016, 06:12 PM   #5 (permalink)
Base Member
 
Join Date: Jul 2016
Location: Chicago IL, San jose CA
Posts: 99
Drives: 16 base coupe
Rep Power: 5
Djvalerio921 is on a distinguished road
Default

This is what my sub has
Attached Images
File Type: jpg image.jpg (191.3 KB, 29 views)
Djvalerio921 is offline   Reply With Quote
Old 08-05-2016, 06:43 PM   #6 (permalink)
A True Z Fanatic
 
ChaseZ's Avatar
 
Join Date: May 2016
Location: Calgary
Posts: 3,799
Drives: 16 370z
Rep Power: 94679
ChaseZ has a reputation beyond reputeChaseZ has a reputation beyond reputeChaseZ has a reputation beyond reputeChaseZ has a reputation beyond reputeChaseZ has a reputation beyond reputeChaseZ has a reputation beyond reputeChaseZ has a reputation beyond reputeChaseZ has a reputation beyond reputeChaseZ has a reputation beyond reputeChaseZ has a reputation beyond reputeChaseZ has a reputation beyond repute
Default

Quote:
Originally Posted by Djvalerio921 View Post
Hello all, I have a set of DB6501s, pioneer avh x4800bs HU with a 500w mono amp withe two 12" subs. After plugging everything in, the speakers were really crappy sounding. It has a crossover menu on it, but not sure on how to adjust the frequencies and lpf/hpf. Could the mid woofer not be pushing any bass because I don't have an amp for it?
Or because of your crossover settings.

I have a similar setup with a pioneer and the crossover adjustments aren't the best, but could be much worse. Don't recall what I have mine set at, and actually have to redo it anyways after my negative terminal was off the other day.

So you're running the Polk 6.5's off deck power and the subs off the amp?
I'd consider even a small 50w rms amp for them if you can swing it.

Double check your polarities to the door speakers? I have mm6501 in mine and they pound pretty good.

Could always turn down the level of the sub on the HU to even things out a bit.
ChaseZ is offline   Reply With Quote
Old 08-05-2016, 09:25 PM   #7 (permalink)
A True Z Fanatic
 
RonRizz's Avatar
 
Join Date: Aug 2011
Location: Pine grove, Pa
Posts: 2,133
Drives: 2 feet, 3 pedals
Rep Power: 6771
RonRizz has a reputation beyond reputeRonRizz has a reputation beyond reputeRonRizz has a reputation beyond reputeRonRizz has a reputation beyond reputeRonRizz has a reputation beyond reputeRonRizz has a reputation beyond reputeRonRizz has a reputation beyond reputeRonRizz has a reputation beyond reputeRonRizz has a reputation beyond reputeRonRizz has a reputation beyond reputeRonRizz has a reputation beyond repute
Default

how are your polks wired to head unit?
__________________
P99rs Head Unit--- Amps- 2 Pioneer Prs800d --- Zapco ST1000MX---Zapco ST-4XSQ---- SI BM mk5 Subs---SI TM65v2 Midbass--- SI M3 mids--- SI M25 xbl2 tweeters ----- 2016 MECA street class 3rd place at world finals
RonRizz is offline   Reply With Quote
Old 08-05-2016, 11:38 PM   #8 (permalink)
Base Member
 
Join Date: Jul 2016
Location: Chicago IL, San jose CA
Posts: 99
Drives: 16 base coupe
Rep Power: 5
Djvalerio921 is on a distinguished road
Default

Quote:
Originally Posted by RonRizz View Post
how are your polks wired to head unit?
Speaker wire spliced into the L/R on the HU harness to polk cross over. Then mid to crossover and tweeters into crossover. Sub and amp through RCAs into HU
Djvalerio921 is offline   Reply With Quote
Old 08-05-2016, 11:42 PM   #9 (permalink)
Base Member
 
Join Date: Jul 2016
Location: Chicago IL, San jose CA
Posts: 99
Drives: 16 base coupe
Rep Power: 5
Djvalerio921 is on a distinguished road
Default

Quote:
Originally Posted by ChaseZ View Post
Or because of your crossover settings.

I have a similar setup with a pioneer and the crossover adjustments aren't the best, but could be much worse. Don't recall what I have mine set at, and actually have to redo it anyways after my negative terminal was off the other day.

So you're running the Polk 6.5's off deck power and the subs off the amp?
I'd consider even a small 50w rms amp for them if you can swing it.

Double check your polarities to the door speakers? I have mm6501 in mine and they pound pretty good.

Could always turn down the level of the sub on the HU to even things out a bit.
Maybe I'll try that. Before I hooked up the sub, I had my lpf filter off on the HU in standard mode (the line graph was flat), and the speakers sounded great, but once I wired the sub and switched over to network mode the frequencies changed and it sounds like the mids aren't doing anything and the tweeters sound like sh*t. Not sure how to adjust from the amp either. Don't wanna take it to my local audio shop because they charged me $180 of labor to do something that took me $20 and 2 hours. So if I can fix this with your guys help that'd be great!
Djvalerio921 is offline   Reply With Quote
Old 08-06-2016, 04:25 AM   #10 (permalink)
A True Z Fanatic
 
RonRizz's Avatar
 
Join Date: Aug 2011
Location: Pine grove, Pa
Posts: 2,133
Drives: 2 feet, 3 pedals
Rep Power: 6771
RonRizz has a reputation beyond reputeRonRizz has a reputation beyond reputeRonRizz has a reputation beyond reputeRonRizz has a reputation beyond reputeRonRizz has a reputation beyond reputeRonRizz has a reputation beyond reputeRonRizz has a reputation beyond reputeRonRizz has a reputation beyond reputeRonRizz has a reputation beyond reputeRonRizz has a reputation beyond reputeRonRizz has a reputation beyond repute
Default

because you are using the polk passive crossover, you should have it set to standard mode, otherwise, ditch the passive crossover, and wire the woofer and tweeter to head unit mid and high outputs, then run in network mode, and use your digital crossover.
bigaudiofanat likes this.
__________________
P99rs Head Unit--- Amps- 2 Pioneer Prs800d --- Zapco ST1000MX---Zapco ST-4XSQ---- SI BM mk5 Subs---SI TM65v2 Midbass--- SI M3 mids--- SI M25 xbl2 tweeters ----- 2016 MECA street class 3rd place at world finals
RonRizz is offline   Reply With Quote
Old 08-06-2016, 04:22 PM   #11 (permalink)
Base Member
 
Join Date: Jul 2016
Location: Chicago IL, San jose CA
Posts: 99
Drives: 16 base coupe
Rep Power: 5
Djvalerio921 is on a distinguished road
Default

Quote:
Originally Posted by RonRizz View Post
because you are using the polk passive crossover, you should have it set to standard mode, otherwise, ditch the passive crossover, and wire the woofer and tweeter to head unit mid and high outputs, then run in network mode, and use your digital crossover.
Hmmm ok. What should I wire the tweeters to? The same as the woofer? I don't believe I have the mid an high outputs.. LOL newbie here
Djvalerio921 is offline   Reply With Quote
Old 08-06-2016, 07:59 PM   #12 (permalink)
Base Member
 
Solid370z's Avatar
 
Join Date: Mar 2013
Location: New Jersey
Posts: 102
Drives: 2011 370z
Rep Power: 8
Solid370z is on a distinguished road
Default

Tune the amp as recommended and leave the EQ on head unit set to flat unless you know what you are doing.

Quote:
Originally Posted by RonRizz View Post
Subwoofer low pass 80hz Components high pass 80hz give that a shot.
^ Those are the settings I have on my amp and it sounds the best.

Last edited by Solid370z; 08-06-2016 at 08:04 PM.
Solid370z is offline   Reply With Quote
Old 08-06-2016, 09:06 PM   #13 (permalink)
A True Z Fanatic
 
RonRizz's Avatar
 
Join Date: Aug 2011
Location: Pine grove, Pa
Posts: 2,133
Drives: 2 feet, 3 pedals
Rep Power: 6771
RonRizz has a reputation beyond reputeRonRizz has a reputation beyond reputeRonRizz has a reputation beyond reputeRonRizz has a reputation beyond reputeRonRizz has a reputation beyond reputeRonRizz has a reputation beyond reputeRonRizz has a reputation beyond reputeRonRizz has a reputation beyond reputeRonRizz has a reputation beyond reputeRonRizz has a reputation beyond reputeRonRizz has a reputation beyond repute
Default

Quote:
Originally Posted by Djvalerio921 View Post
Hmmm ok. What should I wire the tweeters to? The same as the woofer? I don't believe I have the mid an high outputs.. LOL newbie here
Check your manual. when in network mode, your speaker outputs will be... Rear changes to Mid (for woofers) and Front changes to High (for tweeters) I believe.
__________________
P99rs Head Unit--- Amps- 2 Pioneer Prs800d --- Zapco ST1000MX---Zapco ST-4XSQ---- SI BM mk5 Subs---SI TM65v2 Midbass--- SI M3 mids--- SI M25 xbl2 tweeters ----- 2016 MECA street class 3rd place at world finals

Last edited by RonRizz; 08-06-2016 at 09:17 PM.
RonRizz is offline   Reply With Quote
Old 08-10-2016, 07:36 AM   #14 (permalink)
Car Audio Installer
 
bigaudiofanat's Avatar
 
Join Date: Jun 2009
Location: New Castle DE
Posts: 8,323
Drives: 2012 Infiniti G37x
Rep Power: 849
bigaudiofanat has a reputation beyond reputebigaudiofanat has a reputation beyond reputebigaudiofanat has a reputation beyond reputebigaudiofanat has a reputation beyond reputebigaudiofanat has a reputation beyond reputebigaudiofanat has a reputation beyond reputebigaudiofanat has a reputation beyond reputebigaudiofanat has a reputation beyond reputebigaudiofanat has a reputation beyond reputebigaudiofanat has a reputation beyond reputebigaudiofanat has a reputation beyond repute
Send a message via AIM to bigaudiofanat Send a message via Yahoo to bigaudiofanat Send a message via Skype™ to bigaudiofanat
Default

Quote:
Originally Posted by RonRizz View Post
because you are using the polk passive crossover, you should have it set to standard mode, otherwise, ditch the passive crossover, and wire the woofer and tweeter to head unit mid and high outputs, then run in network mode, and use your digital crossover.
Yep this
wideglideleon likes this.
__________________
Need help with car audio or electronics? Let me know!! Also were all my installs will be posted. Need Help Let Me Know
Direct email address reimermatt@gmail.com
Owner of: Dynamic Mobile Audio
bigaudiofanat is offline   Reply With Quote
Old 08-10-2016, 08:18 PM   #15 (permalink)
Premium Member
 
Jayhovah's Avatar
 
Join Date: May 2013
Location: St. Pete, FL
Posts: 3,795
Drives: 520whp Fire Breather
Rep Power: 80227
Jayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond reputeJayhovah has a reputation beyond repute
Default

Quote:
Originally Posted by RonRizz View Post
Check your manual. when in network mode, your speaker outputs will be... Rear changes to Mid (for woofers) and Front changes to High (for tweeters) I believe.
As as aside... I just ordered a pioneer head unit after I discovered the existence of network mode. It's a feature I have wanted for many years!!!

I previously didn't consider the pioneers because they don't have a volume knob... but I had to have the network mode, particularly since I want to drive the front speakers off the HU.

Does anyone happen to know where the factory speaker crossover point is?
__________________
2013 Gun Metallic Sport - Gamma V3 Twin Turbogized
DIY Gamma V3 TT Install * Jayhovah's Gamma V3 TT Install Pic'Z and Vid'Z * DIY: Washer Reservoir for the Boosted
Quote:
Originally Posted by redondoaveb
You've got a twin turbo sound system, I think you met your audio goals.
Jayhovah is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Next Z a Crossover? GOBLUE Nissan 370Z General Discussions 3 08-26-2015 04:40 PM
Anyone have experience with radio frequencies? Cell The Lounge (Off Topic) 5 10-16-2014 09:21 PM
even radio frequencies twofour1 Audio & Video 3 03-13-2013 08:31 PM
Adjusting crossover Baer383 Audio & Video 4 03-04-2011 10:14 AM
Crossover Help zero610 Audio & Video 17 06-27-2009 06:29 PM


All times are GMT -5. The time now is 09:56 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 PL2