Nissan 370Z Forum  

Camshaft/Crankshaft Sensor, Limp Mode, Z issues :/

So, car (2014 Nismo Z) went into limp mode randomly and died in my work parking lot. Anything over 3500 RPMS and it would go into Limp mode (Felt like

Go Back   Nissan 370Z Forum > Tech Area > Nissan 370Z Warranty / Scheduled Maintenance / Servicing / Repairs

Reply
 
LinkBack Thread Tools Display Modes
Old 02-10-2018, 02:57 PM   #1 (permalink)
Base Member
 
Join Date: Jan 2014
Location: Northern NJ
Posts: 230
Drives: 14 Nissan 370z Nismo
Rep Power: 198
d0ubts has a reputation beyond reputed0ubts has a reputation beyond reputed0ubts has a reputation beyond reputed0ubts has a reputation beyond reputed0ubts has a reputation beyond reputed0ubts has a reputation beyond reputed0ubts has a reputation beyond reputed0ubts has a reputation beyond reputed0ubts has a reputation beyond reputed0ubts has a reputation beyond reputed0ubts has a reputation beyond repute
Default Camshaft/Crankshaft Sensor, Limp Mode, Z issues :/

So, car (2014 Nismo Z) went into limp mode randomly and died in my work parking lot.

Anything over 3500 RPMS and it would go into Limp mode (Felt like hitting brakes)

Scan read Camshaft Sensor Bank 1 so ordered that piece and replaced it (30 second job), but the car still wouldn't start.

it would crank but not fire.

Funny thing is if you pull the sensor the car will start but in limp mode still.

Trying to see if its:
1. Wiring
2. More Sensor issues (Crankshaft)
3. Flywheel
4. Camshaft sprocket\
5. ECU
6.God knows.

Anyone can assist?
d0ubts is offline   Reply With Quote
Old 02-10-2018, 03:51 PM   #2 (permalink)
Base Member
 
Join Date: Oct 2017
Location: El paso
Posts: 7
Drives: 2011 370z PW 6MT
Rep Power: 2
Andrewbull is on a distinguished road
Default

So this happened to me but it was my crank sensor, no cam sensors threw codes or anything. Couldn't figure it out, had it looked at and they found my flywheel had a couple teeth messed up from grinding against the sensor
Andrewbull is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Crankshaft position sensor location wideglideleon Engine & Drivetrain 4 06-09-2018 12:49 PM
Crankshaft sensor/limp mode Andrewbull Nissan 370Z Warranty / Scheduled Maintenance / Servicing / Repairs 7 02-06-2018 06:00 PM
[WTB] Camshaft Sensor Harness Z_Society Parts for sale (Private Classifieds) 0 03-05-2016 06:17 PM
Help. Locating Camshaft Position Sensor itsEz DIY Section (Do-It-Yourself) 2 02-20-2016 12:18 PM
Oil Temp issues + Limp Mode....HOW!!!??? kannibul Nissan 370Z General Discussions 16 06-28-2009 11:54 AM


All times are GMT -5. The time now is 03:45 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 PL2