Nissan 370Z Forum  

Couple questions. Probably simple answers!

Hello, I've joined the forum not too long ago and planned on being very active which hasn't been the case. School and work has been getting in the way. Anyway,

Go Back   Nissan 370Z Forum > Tech Area > Nissan 370Z Warranty / Scheduled Maintenance / Servicing / Repairs

Like Tree3Likes
  • 1 Post By TerribleONE
  • 2 Post By kenchan

Reply
 
LinkBack Thread Tools Display Modes
Old 11-16-2015, 03:28 PM   #1 (permalink)
Base Member
 
Join Date: Jul 2015
Location: United States
Posts: 30
Drives: 17 370Z Black M6
Rep Power: 5
Proposed is on a distinguished road
Default Couple questions. Probably simple answers!

Hello,
I've joined the forum not too long ago and planned on being very active which hasn't been the case. School and work has been getting in the way. Anyway, to get straight to the point I have two questions (I could use the search, I prefer my own discussions) 1. During heavy acceleration I'm getting an almost rotten egg or sulfur smell. I believe this is caused by the CAT correct? If this is the case will the Berk HFCS I just ordered help the problem? 2. With Trac Control off certain times on acceleration and specific places the brake light pops on and off while also producing a solid slip light. Is this just caused by break fluid being slightly low? If this is the case it should be fixed when I get all the fluids checked this week.

Thanks for any and all help!
Proposed is offline   Reply With Quote
Old 11-16-2015, 03:48 PM   #2 (permalink)
Premium Member
 
TerribleONE's Avatar
 
Join Date: Jan 2009
Location: Socal
Posts: 10,195
Drives: WOT
Rep Power: 2490
TerribleONE has a reputation beyond reputeTerribleONE has a reputation beyond reputeTerribleONE has a reputation beyond reputeTerribleONE has a reputation beyond reputeTerribleONE has a reputation beyond reputeTerribleONE has a reputation beyond reputeTerribleONE has a reputation beyond reputeTerribleONE has a reputation beyond reputeTerribleONE has a reputation beyond reputeTerribleONE has a reputation beyond reputeTerribleONE has a reputation beyond repute
Default

Quote:
Originally Posted by Proposed View Post
Hello,
I've joined the forum not too long ago and planned on being very active which hasn't been the case. School and work has been getting in the way. Anyway, to get straight to the point I have two questions (I could use the search, I prefer my own discussions) 1. During heavy acceleration I'm getting an almost rotten egg or sulfur smell. I believe this is caused by the CAT correct? If this is the case will the Berk HFCS I just ordered help the problem? 2. With Trac Control off certain times on acceleration and specific places the brake light pops on and off while also producing a solid slip light. Is this just caused by break fluid being slightly low? If this is the case it should be fixed when I get all the fluids checked this week.

Thanks for any and all help!
1.Not sure about this one. How many miles are on the car??

2. Your brake fluid is low
jaytirbhaw likes this.
__________________
638WHP 541WTQ @ 13.5PSI
Build thread
TerribleONE is offline   Reply With Quote
Old 11-16-2015, 03:50 PM   #3 (permalink)
Track Member
 
jaytirbhaw's Avatar
 
Join Date: Dec 2009
Location: NYC
Posts: 814
Drives: 350z HR , Nismo 370z
Rep Power: 11
jaytirbhaw has a spectacular aura aboutjaytirbhaw has a spectacular aura aboutjaytirbhaw has a spectacular aura about
Default

sometimes that smell is from mildew build up, in the vents. I cant remember what the fix was, but the dealer took care of it on my end when I had it. Edit: Could also just be the cats heating up

As for the lights, sounds like it just detected some wheel spin ...although i've never seen the brake light pop on for this.
__________________
2014 Nismo #350 , Built Motor, Top Mount Single Turbo .... 620 whp/ 500 lbs wtq
2012 Track/Drift Z, build coming soon.
Build Thread - http://www.the370z.com/members-370z-...70z-build.html

Last edited by jaytirbhaw; 11-16-2015 at 03:53 PM.
jaytirbhaw is offline   Reply With Quote
Old 11-16-2015, 03:51 PM   #4 (permalink)
Premium Member
 
TerribleONE's Avatar
 
Join Date: Jan 2009
Location: Socal
Posts: 10,195
Drives: WOT
Rep Power: 2490
TerribleONE has a reputation beyond reputeTerribleONE has a reputation beyond reputeTerribleONE has a reputation beyond reputeTerribleONE has a reputation beyond reputeTerribleONE has a reputation beyond reputeTerribleONE has a reputation beyond reputeTerribleONE has a reputation beyond reputeTerribleONE has a reputation beyond reputeTerribleONE has a reputation beyond reputeTerribleONE has a reputation beyond reputeTerribleONE has a reputation beyond repute
Default

Quote:
Originally Posted by jaytirbhaw View Post
sometimes that smell is from mildew build up, in the vents. I cant remember what the fix was, but the dealer took care of it on my end when I had it.

As for the lights, sounds like it just detected some wheel spin ...although i've never seen the brake light pop on for this.
Could be it. Just didn't think going WOT would have anything to do with this.
__________________
638WHP 541WTQ @ 13.5PSI
Build thread
TerribleONE is offline   Reply With Quote
Old 11-16-2015, 04:04 PM   #5 (permalink)
Base Member
 
Join Date: Jul 2015
Location: United States
Posts: 30
Drives: 17 370Z Black M6
Rep Power: 5
Proposed is on a distinguished road
Default

Quote:
Originally Posted by TerribleONE View Post
1.Not sure about this one. How many miles are on the car??

2. Your brake fluid is low
1. There's about 37,000 miles on it. 2012 7AT
2. That's what I was assuming. I'm changing oil and checking fluids today.
Proposed is offline   Reply With Quote
Old 11-17-2015, 04:01 PM   #6 (permalink)
A True Z Fanatic
 
Join Date: Aug 2009
Location: N/A
Posts: 76,801
Drives: N/A
Rep Power: 141516
kenchan has a reputation beyond reputekenchan has a reputation beyond reputekenchan has a reputation beyond reputekenchan has a reputation beyond reputekenchan has a reputation beyond reputekenchan has a reputation beyond reputekenchan has a reputation beyond reputekenchan has a reputation beyond reputekenchan has a reputation beyond reputekenchan has a reputation beyond reputekenchan has a reputation beyond repute
Default

Quote:
Originally Posted by TerribleONE View Post
Could be it. Just didn't think going WOT would have anything to do with this.
could be the driver releasing gas from all the excitement...



probably cats.
TerribleONE and wideglideleon like this.
kenchan is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Couple questions Ab_h Wanted 2 06-28-2015 10:10 AM
Got my z....Couple questions ? Samiam Nissan 370Z General Discussions 5 07-05-2013 09:41 PM
Couple BC BR Questions MattP725 Brakes & Suspension 13 04-03-2012 02:26 PM
Just a night, and a couple of simple photos. memorylasts Member's 370Z Gallery 22 09-29-2010 05:23 PM
a couple questions: Lenny Nissan 370Z General Discussions 17 09-01-2010 12:57 PM


All times are GMT -5. The time now is 06:32 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 PL2