Nissan 370Z Forum  

"Service engine soon" light

I am dropping it off at the dealer this evening. Will post what is discovered.

Go Back   Nissan 370Z Forum > Tech Area > Engine & Drivetrain

Like Tree4Likes

Reply
 
LinkBack Thread Tools Display Modes
Old 10-20-2009, 02:00 PM   #31 (permalink)
Base Member
 
Rhinetom's Avatar
 
Join Date: Sep 2009
Location: United States
Posts: 92
Drives: 09 370Z auto, red
Rep Power: 10
Rhinetom is on a distinguished road
Default Service Engine Light at 1200 mi

I am dropping it off at the dealer this evening. Will post what is discovered.
Rhinetom is offline   Reply With Quote
Old 10-20-2009, 04:51 PM   #32 (permalink)
Base Member
 
Echo's Avatar
 
Join Date: Aug 2009
Location: Puget Sound
Posts: 13
Drives: 09 7AT MB Base Sport
Rep Power: 10
Echo is on a distinguished road
Default

Looking at my car in the dealer's service bay as we speak. Last time they chastised me for not putting the gas cap on tightly. Even though I knew it was I let them have their say. Today, I am not taking that BS as an excuse. I want an answer. And while I am here, I also have the moving driver seat issue that they need to look at. That issue has been posted in another thread that I won't try to co-opt into this thread, but I'll keep you posted on both issues.
Echo is offline   Reply With Quote
Old 10-20-2009, 04:55 PM   #33 (permalink)
A True Z Fanatic
 
370Zsteve's Avatar
 
Join Date: Sep 2009
Location: Gold Coast CT
Posts: 10,596
Drives: 2019 Corvette G.S.
Rep Power: 34
370Zsteve has a reputation beyond repute370Zsteve has a reputation beyond repute370Zsteve has a reputation beyond repute370Zsteve has a reputation beyond repute370Zsteve has a reputation beyond repute370Zsteve has a reputation beyond repute370Zsteve has a reputation beyond repute370Zsteve has a reputation beyond repute370Zsteve has a reputation beyond repute370Zsteve has a reputation beyond repute370Zsteve has a reputation beyond repute
Default

Quote:
Originally Posted by molamann View Post
Oh man, I had evap OBD-II code haunt me throughout the entire time I owned my Camaro. Hope it doesn't haunt me with the Z. :/
Same here with a Ford Expedition. I know the smoke test very well.
__________________
SOLD MY Z MARCH 2018 - another Core OG moves on - new ride 2019 Z Corvette Grand Sport - no mods necessary but already have eyes on HFC and intakes LOL IT NEVER ENDS.
370Zsteve is offline   Reply With Quote
Old 10-20-2009, 05:05 PM   #34 (permalink)
Base Member
 
Echo's Avatar
 
Join Date: Aug 2009
Location: Puget Sound
Posts: 13
Drives: 09 7AT MB Base Sport
Rep Power: 10
Echo is on a distinguished road
Default

LMAO, I just walked out to the service bay to demonstrate that my gas cap is totally loose. As I am walking back to the waiting area one of the service techs is busy keeping up to date on Facebook. Is this why my service charges are $500 an hour? For him to spend his time on Facebook?
Echo is offline   Reply With Quote
Old 10-21-2009, 12:02 PM   #35 (permalink)
Base Member
 
Rhinetom's Avatar
 
Join Date: Sep 2009
Location: United States
Posts: 92
Drives: 09 370Z auto, red
Rep Power: 10
Rhinetom is on a distinguished road
Cool Service Engine = Loose Gas Cap

The dealer just called me. The Service Engine Soon light came on because the gas cap was not tight enough. Tech said to tighten it for 10 clicks. He said other new Nissans are having the same issue.
Rhinetom is offline   Reply With Quote
Old 10-21-2009, 03:55 PM   #36 (permalink)
Base Member
 
Echo's Avatar
 
Join Date: Aug 2009
Location: Puget Sound
Posts: 13
Drives: 09 7AT MB Base Sport
Rep Power: 10
Echo is on a distinguished road
Default

Quote:
Originally Posted by Rhinetom View Post
The dealer just called me. The Service Engine Soon light came on because the gas cap was not tight enough. Tech said to tighten it for 10 clicks. He said other new Nissans are having the same issue.
The service adviser, the technician and myself all spent about 5 minutes playing with my gas cap yesterday. Very clearly, when you start to tighten it down, there are some orientations that work and some that don't. We could each start it one way and the cap would tighten nicely. But, if we rotated the cap 180 degrees before starting it the next time, it wouldn't tighten at all. They have a new cap on order for me. I should know by Friday if that fixes the issue.
Echo is offline   Reply With Quote
Old 10-28-2009, 04:25 PM   #37 (permalink)
Base Member
 
Zcott's Avatar
 
Join Date: Jun 2009
Location: D/FW, Texas
Posts: 89
Drives: 09 370Z Sport PG M6
Rep Power: 10
Zcott is on a distinguished road
Default

My light just came on today... but I only have about 1/4 of a tank left, so I find it hard to believe my gas cap is the problem.
Guess I'll be going down to the dealer to see what they say....
Zcott is offline   Reply With Quote
Old 10-28-2009, 08:12 PM   #38 (permalink)
Track Member
 
import111's Avatar
 
Join Date: Feb 2009
Location: Tucson, AZ.
Posts: 622
Drives: 09 Nissan 370Z
Rep Power: 185
import111 has a reputation beyond reputeimport111 has a reputation beyond reputeimport111 has a reputation beyond reputeimport111 has a reputation beyond reputeimport111 has a reputation beyond reputeimport111 has a reputation beyond reputeimport111 has a reputation beyond reputeimport111 has a reputation beyond reputeimport111 has a reputation beyond reputeimport111 has a reputation beyond reputeimport111 has a reputation beyond repute
Send a message via Yahoo to import111
Default

Mine has gone away on it's own before I could get to the dealer. 3rd time I have had the SES light. Oh well.
import111 is offline   Reply With Quote
Old 03-09-2010, 02:15 PM   #39 (permalink)
Base Member
 
Join Date: Jun 2009
Location: Manila, Philippines
Posts: 89
Drives: Evo ix, Nismo 370z
Rep Power: 258
Baddriver has a reputation beyond reputeBaddriver has a reputation beyond reputeBaddriver has a reputation beyond reputeBaddriver has a reputation beyond reputeBaddriver has a reputation beyond reputeBaddriver has a reputation beyond reputeBaddriver has a reputation beyond reputeBaddriver has a reputation beyond reputeBaddriver has a reputation beyond reputeBaddriver has a reputation beyond reputeBaddriver has a reputation beyond repute
Default

Hello guys,

I need help. I have a p0456 code (small evap leak). This may not be a problem with Americans since your cars are under warranty, I imported my car from the states to asia so my local Nissan dealers don't cover it. besides, they are unfamiliar with the 370z since it has yet to come out locally.

my question is, can anyone tell me which part to replace in order for me to fix this? part number please?

Note: I've cleared the code a few times already and making sure the gas cap is always tight but it still comes back.

THANKS!
Faryas likes this.
Baddriver is offline   Reply With Quote
Old 03-10-2010, 05:58 AM   #40 (permalink)
A True Z Fanatic
 
1slow370's Avatar
 
Join Date: Aug 2009
Location: Wiscy(at heart)
Posts: 3,579
Drives: 09 370z sport manual
Rep Power: 484
1slow370 has a reputation beyond repute1slow370 has a reputation beyond repute1slow370 has a reputation beyond repute1slow370 has a reputation beyond repute1slow370 has a reputation beyond repute1slow370 has a reputation beyond repute1slow370 has a reputation beyond repute1slow370 has a reputation beyond repute1slow370 has a reputation beyond repute1slow370 has a reputation beyond repute1slow370 has a reputation beyond repute
Default

you have to turn the cap until it clicks several times not just tight. My first job was as a service attendant at a gas station and we had to do it to all newer cars we usually gave them 2 or three turns around to make sure. those damn caps do break eventually i'm thinking the stant instantfill cap in one of the threads here might be one of my next purchases just because it's cool.
__________________
ANSWER PRICE LIST
Answers - - - - - - - - - - - - - - - - $0.75
Answers (requiring thought) - - - - $1.25
Answers (correct) - - - - - - - - - - $12.50
1slow370 is offline   Reply With Quote
Old 03-10-2010, 08:56 AM   #41 (permalink)
Banned
 
j.arnaldo's Avatar
 
Join Date: Oct 2009
Location: Puerto Rico
Posts: 937
Drives: Nissan 350Z, 2004
Rep Power: 0
j.arnaldo is on a distinguished road
Default

Maybe in newer cars the "Service Engine Soon" pilot light implies something serious, but in older cars (say, mid-to-late 90s) it just indicates that the stealership's gonna make some $$ off of you. My mother's 1997 Ford Escort has had it on since the early 2000s, with no consequences at all. I spoke to a friend who's an ace in computer diagnostics issues, and told me that's just a gimmick car manufacturers use to scare customers into going to the stealership to have them reset it, for which they charge $weet $$ for them. Obviously, it's $our $$ for us! My 2004 Touring Coupe's doing great, so far--SO HELP ME GOD!!! Greetings.
j.arnaldo is offline   Reply With Quote
Old 03-10-2010, 10:20 AM   #42 (permalink)
A True Z Fanatic
 
1slow370's Avatar
 
Join Date: Aug 2009
Location: Wiscy(at heart)
Posts: 3,579
Drives: 09 370z sport manual
Rep Power: 484
1slow370 has a reputation beyond repute1slow370 has a reputation beyond repute1slow370 has a reputation beyond repute1slow370 has a reputation beyond repute1slow370 has a reputation beyond repute1slow370 has a reputation beyond repute1slow370 has a reputation beyond repute1slow370 has a reputation beyond repute1slow370 has a reputation beyond repute1slow370 has a reputation beyond repute1slow370 has a reputation beyond repute
Default

please don't get into the habit of ignore the idiot light it does mean real things are happening it's just that it is mostly california and the epa's fault for putting so many god damn emissions related parts on cars now that one or two of the hundreds of the little bastards is bound to break eventually and then the stupid light comes on. my advice is take it to an auto parts store they can read and clear the codes for free, and sell you a code reader if you want to do it yourself even. it's how i found out the o2 sensor took a crap on my neon but when it said it was sensor 2 (emmisions only) i just kept ignoring it but at least i knew what it was.
__________________
ANSWER PRICE LIST
Answers - - - - - - - - - - - - - - - - $0.75
Answers (requiring thought) - - - - $1.25
Answers (correct) - - - - - - - - - - $12.50
1slow370 is offline   Reply With Quote
Old 03-22-2010, 01:37 PM   #43 (permalink)
Base Member
 
Join Date: Feb 2010
Location: California
Posts: 2
Drives: 2010 370Z Roadster
Rep Power: 9
2010370z is on a distinguished road
Default

My SES light came on on my 370Z Roadster over the weekend. Only had 1,090 miles on it. Bought it back in January of this year. Took it to the dealership this morning and, apparently, a small evap leak was discovered. So, now just waiting to see what's happening. Luckily, still under warranty but....still sucks.
2010370z is offline   Reply With Quote
Old 03-22-2010, 11:28 PM   #44 (permalink)
Base Member
 
Join Date: Feb 2010
Location: California
Posts: 2
Drives: 2010 370Z Roadster
Rep Power: 9
2010370z is on a distinguished road
Default

Cause of problem...and I am quoting the invoice..."Found evap code P0456. Evap small leak. Pinpoint test found vent control valve sticking cause of concern. Replace control valve and rechk operation- okay at this time".

Again, glad it is still under warrant. Repairs were completed in the morning and have the car back already.
2010370z is offline   Reply With Quote
Old 03-22-2010, 11:41 PM   #45 (permalink)
A True Z Fanatic
 
Red370's Avatar
 
Join Date: Jul 2009
Location: Kaiserslautern, Germany
Posts: 4,391
Drives: your mom to church
Rep Power: 290
Red370 has a reputation beyond reputeRed370 has a reputation beyond reputeRed370 has a reputation beyond reputeRed370 has a reputation beyond reputeRed370 has a reputation beyond reputeRed370 has a reputation beyond reputeRed370 has a reputation beyond reputeRed370 has a reputation beyond reputeRed370 has a reputation beyond reputeRed370 has a reputation beyond reputeRed370 has a reputation beyond repute
Default

wtf? how could a brand new car like that have issues already? I'm modded to the hilt and only SES I got was because my HFC's were tripping my 02's, stuffed some steel wool in those bitches and havent got the light since.
__________________
2011 Mustang 5.0 | 3.55's | Lethal Performance off road H-Pipe | Magnaflow Muffler Delete | JLT CAI/Bama tuned 417whp/ 404 ft/lbs
Red370 is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Question about the Euro Spec. rear "Fog Light" Arizona Z Exterior & Interior 7 03-26-2010 09:01 AM
Break in - drive it "hard" or "be gentle"? kannibul Engine & Drivetrain 3 06-06-2009 02:51 AM
Any Update on the "Rear Fog Light" Arizona Z Nissan 370Z General Discussions 4 05-10-2009 12:21 AM
Bicycles that make you go "wow" or "eww" frost The Lounge (Off Topic) 6 04-29-2009 09:49 PM
HELP!!!! Service engine light came on tru_Asiatik Engine & Drivetrain 31 04-15-2009 08:38 PM


All times are GMT -5. The time now is 01:56 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 PL2