Nissan 370Z Forum  

Radiator fan stuck on full speed

Both fans of my radiator turn on full speed as soon as I turn on the car. It could be 40F outside or 100F, it'll just be at max at

Go Back   Nissan 370Z Forum > Tech Area > Engine & Drivetrain

Like Tree2Likes
  • 1 Post By SouthArk370Z
  • 1 Post By jwick

Reply
 
LinkBack Thread Tools Display Modes
Old 01-04-2019, 05:52 PM   #1 (permalink)
Enthusiast Member
 
EndyKwon's Avatar
 
Join Date: Jan 2012
Location: Los Angeles
Posts: 416
Drives: '11 BSilver Base 7AT
Rep Power: 9
EndyKwon is on a distinguished road
Default Radiator fan stuck on full speed

Both fans of my radiator turn on full speed as soon as I turn on the car. It could be 40F outside or 100F, it'll just be at max at all times. Every now and then I can hear the fan speed fluctuating down to like 80% speed, but I can't figure out what's causing it.

My coolant temp gauge shows normal temps, below the middle. I tried switching out the fan relay (PWM RAD FAN RELAY) and that didn't work either.

What else could be causing this?

I tried cycling the AC to see if it'll stop it.. nothing.
EndyKwon is online now   Reply With Quote
Old 01-04-2019, 06:19 PM   #2 (permalink)
Premium Member
 
SouthArk370Z's Avatar
 
Join Date: Nov 2010
Location: South Arkansas
Posts: 8,130
Drives: 2014 Challenger
Rep Power: 233595
SouthArk370Z has a reputation beyond reputeSouthArk370Z has a reputation beyond reputeSouthArk370Z has a reputation beyond reputeSouthArk370Z has a reputation beyond reputeSouthArk370Z has a reputation beyond reputeSouthArk370Z has a reputation beyond reputeSouthArk370Z has a reputation beyond reputeSouthArk370Z has a reputation beyond reputeSouthArk370Z has a reputation beyond reputeSouthArk370Z has a reputation beyond reputeSouthArk370Z has a reputation beyond repute
Default

First thing I'd do is check all the connectors in the circuit for looseness, corrosion, bent pins, etc. Connector and wiring harness locations (and much more) are in the FSM (link in sig).
EndyKwon likes this.
__________________
Steering Lock Links - Search The370Z Bookmarklet - FSM @ NICOclub
Mankind has progressed past the need for war but we haven't evolved that far. - NachoMahma
SouthArk370Z is offline   Reply With Quote
Old 01-04-2019, 06:29 PM   #3 (permalink)
Enthusiast Member
 
EndyKwon's Avatar
 
Join Date: Jan 2012
Location: Los Angeles
Posts: 416
Drives: '11 BSilver Base 7AT
Rep Power: 9
EndyKwon is on a distinguished road
Default

Quote:
Originally Posted by SouthArk370Z View Post
First thing I'd do is check all the connectors in the circuit for looseness, corrosion, bent pins, etc. Connector and wiring harness locations (and much more) are in the FSM (link in sig).
I'll give it a good read right now. Thank you!
EndyKwon is online now   Reply With Quote
Old 01-04-2019, 06:34 PM   #4 (permalink)
I's the first...
 
jwick's Avatar
 
Join Date: Dec 2010
Location: Houston
Posts: 14,254
Drives: '10 G37 6MT
Rep Power: 1502217
jwick has a reputation beyond reputejwick has a reputation beyond reputejwick has a reputation beyond reputejwick has a reputation beyond reputejwick has a reputation beyond reputejwick has a reputation beyond reputejwick has a reputation beyond reputejwick has a reputation beyond reputejwick has a reputation beyond reputejwick has a reputation beyond reputejwick has a reputation beyond repute
Default

Did this just randomly occur? Did you get a tune recently?

My tune is setup up for 100% fan all the time.
elhombre likes this.
__________________
'10 G37T 6MT Graphite/Graphite - BP - G37T Build

jwick is online now   Reply With Quote
Old 01-07-2019, 01:39 PM   #5 (permalink)
Enthusiast Member
 
EndyKwon's Avatar
 
Join Date: Jan 2012
Location: Los Angeles
Posts: 416
Drives: '11 BSilver Base 7AT
Rep Power: 9
EndyKwon is on a distinguished road
Default

Quote:
Originally Posted by jwick View Post
Did this just randomly occur? Did you get a tune recently?

My tune is setup up for 100% fan all the time.
No, it just came up out of nowhere. Car is 100% stock

Is it bad for the car to be at 100% fan? I mean, I'm sure the extra cooling will be nice in the summer..
EndyKwon is online now   Reply With Quote
Old 02-13-2019, 11:39 AM   #6 (permalink)
Base Member
 
FastZNuff's Avatar
 
Join Date: May 2017
Location: California
Posts: 7
Drives: 2014 370Z-SRS-M6
Rep Power: 4
FastZNuff is on a distinguished road
Default

I am having this same issue going on with my car. It did it this morning and it was 34 degrees.. Lol. Would love to know if this is bad or not for the car!
FastZNuff is offline   Reply With Quote
Old 02-13-2019, 11:46 AM   #7 (permalink)
Drives below cars ability
 
mults's Avatar
 
Join Date: Aug 2011
Location: Cleveland, OH
Age: 65
Posts: 1,830
Drives: 2010 (40th) #706
Rep Power: 16882
mults has a reputation beyond reputemults has a reputation beyond reputemults has a reputation beyond reputemults has a reputation beyond reputemults has a reputation beyond reputemults has a reputation beyond reputemults has a reputation beyond reputemults has a reputation beyond reputemults has a reputation beyond reputemults has a reputation beyond reputemults has a reputation beyond repute
Default

Fans will run if the A/C is turned on regardless of the outside temp...
__________________
mults
40th Anniversary 'Z', 312.06HP/260.58TQ (Dynosty EcuTek Tune)
Build Date/Number: 1/27/2010 #706
Berk HFC + CBE, R2C CAI, Clear Bra, Cleveland Z Club
mults is offline   Reply With Quote
Old 02-13-2019, 04:04 PM   #8 (permalink)
Enthusiast Member
 
Join Date: Dec 2010
Location: new jersey
Posts: 339
Drives: 2011 MB 370Z NISMO
Rep Power: 10
fryzia23 has a spectacular aura aboutfryzia23 has a spectacular aura about
Default

Fan control module most likely shorted. Usually this would be caused by stuck temp switch or relay but I believe our cars get the fan on/off switch straight from Ecu to the fan control at the fan shroud.
fryzia23 is offline   Reply With Quote
Old 08-24-2019, 08:48 PM   #9 (permalink)
Base Member
 
Join Date: Sep 2018
Location: Richmond, VA
Posts: 100
Drives: 2011 370z Gray 7AT
Rep Power: 3
Nooree01 is on a distinguished road
Default

Quote:
Originally Posted by fryzia23 View Post
Fan control module most likely shorted. Usually this would be caused by stuck temp switch or relay but I believe our cars get the fan on/off switch straight from Ecu to the fan control at the fan shroud.
Which temp switch are you talking about?
I am having the same problem and I know my ambient temps switch is bad

Sent from my SM-G975U using Tapatalk
Nooree01 is offline   Reply With Quote
Old 08-24-2019, 09:02 PM   #10 (permalink)
Enthusiast Member
 
Join Date: Dec 2010
Location: new jersey
Posts: 339
Drives: 2011 MB 370Z NISMO
Rep Power: 10
fryzia23 has a spectacular aura aboutfryzia23 has a spectacular aura about
Default

Our cars fan isn't switch controlled. The control module gets signal directly from ECU to turn on/off the fan based off of coolant temperature sensor. So if your temp on dash is correct then the ECU gets proper coolant temp. Faulty ambient temperature sensor would cause issues with heat or ac not functioning correctly. Nothing to do with radiator fan.
fryzia23 is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[FOR SALE] Top Speed Pro1 Full CBE Trutactix Parts for sale (Private Classifieds) 10 05-16-2016 09:33 PM
[FOR SALE] Top Speed Pro 1 FULL TITANIUM EXHAUST cycy89 Parts for sale (Private Classifieds) 22 03-11-2015 02:02 PM
Fuel Gage stuck .. indicating near full sancle Exterior & Interior 3 06-25-2013 03:22 PM
Anyone else have their gas gauge stuck on Full? VCuomo Nissan 370Z General Discussions 21 11-04-2010 07:45 PM


All times are GMT -5. The time now is 12:30 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 PL2