Nissan 370Z Forum

Nissan 370Z Forum (http://www.the370z.com/)
-   Engine & Drivetrain (http://www.the370z.com/engine-drivetrain/)
-   -   Radiator fan stuck on full speed (http://www.the370z.com/engine-drivetrain/129488-radiator-fan-stuck-full-speed.html)

EndyKwon 01-04-2019 05:52 PM

Radiator fan stuck on full speed
 
Both fans of my radiator turn on full speed as soon as I turn on the car. It could be 40F outside or 100F, it'll just be at max at all times. Every now and then I can hear the fan speed fluctuating down to like 80% speed, but I can't figure out what's causing it.

My coolant temp gauge shows normal temps, below the middle. I tried switching out the fan relay (PWM RAD FAN RELAY) and that didn't work either.

What else could be causing this?

I tried cycling the AC to see if it'll stop it.. nothing.

SouthArk370Z 01-04-2019 06:19 PM

First thing I'd do is check all the connectors in the circuit for looseness, corrosion, bent pins, etc. Connector and wiring harness locations (and much more) are in the FSM (link in sig).

EndyKwon 01-04-2019 06:29 PM

Quote:

Originally Posted by SouthArk370Z (Post 3812252)
First thing I'd do is check all the connectors in the circuit for looseness, corrosion, bent pins, etc. Connector and wiring harness locations (and much more) are in the FSM (link in sig).

I'll give it a good read right now. Thank you!

jwick 01-04-2019 06:34 PM

Did this just randomly occur? Did you get a tune recently?

My tune is setup up for 100% fan all the time.

EndyKwon 01-07-2019 01:39 PM

Quote:

Originally Posted by jwick (Post 3812255)
Did this just randomly occur? Did you get a tune recently?

My tune is setup up for 100% fan all the time.

No, it just came up out of nowhere. Car is 100% stock :confused:

Is it bad for the car to be at 100% fan? I mean, I'm sure the extra cooling will be nice in the summer..

FastZNuff 02-13-2019 11:39 AM

I am having this same issue going on with my car. It did it this morning and it was 34 degrees.. Lol. Would love to know if this is bad or not for the car!

mults 02-13-2019 11:46 AM

Fans will run if the A/C is turned on regardless of the outside temp...

fryzia23 02-13-2019 04:04 PM

Fan control module most likely shorted. Usually this would be caused by stuck temp switch or relay but I believe our cars get the fan on/off switch straight from Ecu to the fan control at the fan shroud.

Nooree01 08-24-2019 08:48 PM

Quote:

Originally Posted by fryzia23 (Post 3824690)
Fan control module most likely shorted. Usually this would be caused by stuck temp switch or relay but I believe our cars get the fan on/off switch straight from Ecu to the fan control at the fan shroud.

Which temp switch are you talking about?
I am having the same problem and I know my ambient temps switch is bad

Sent from my SM-G975U using Tapatalk

fryzia23 08-24-2019 09:02 PM

Our cars fan isn't switch controlled. The control module gets signal directly from ECU to turn on/off the fan based off of coolant temperature sensor. So if your temp on dash is correct then the ECU gets proper coolant temp. Faulty ambient temperature sensor would cause issues with heat or ac not functioning correctly. Nothing to do with radiator fan.


All times are GMT -5. The time now is 03:15 PM.

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 PL2