Nissan 370Z Forum  

JL shipped me a turd in a box labelled W3 for $159

So, I turn on my car today and notice that my bass sounds significantly quieter. Hmmnm, I've only had my stereo installed for 3 weeks, so what could be the

Go Back   Nissan 370Z Forum > Nissan 370Z Tech Area > Audio & Video

Reply
 
LinkBack Thread Tools Display Modes
Old 05-26-2012, 08:00 PM   #1 (permalink)
A True Z Fanatic
 
Vertigo's Avatar
 
Join Date: Dec 2011
Location: Philadelphia
Posts: 15,476
Drives: 370z / R32
Rep Power: 217
Vertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond repute
Send a message via AIM to Vertigo
Default JL shipped me a turd in a box labelled W3 for $159

So, I turn on my car today and notice that my bass sounds significantly quieter. Hmmnm, I've only had my stereo installed for 3 weeks, so what could be the problem? I open my hatch and only 1 of my 10" JL W3V3's is working I check the speaker wire connections from my amp to the box terminal of the nonworking sub and it seems to be just fine, but still no sound from the speaker.

Next, I remove my nonworking sub from the box and check the connection from my sub to the inside of the box terminal, and all seems to be fine, but still no sound from the speaker. I'm thinking, there's no way this sub could be malfunctioning after only 3 weeks of use at moderate power (approx 300RMS per sub); not a sub that JL praises due to it's reliability.. Finally, I decide to use the speaker wire that's going from my amp to my working sub's terminal, disconnect it from the terminal, and connect it to the + and - connections on my nonworking JL sub and it connects, but still no sound from the speaker.

In summary: All of the connections done by bigaudiofanat held up and JL's product failed miserably after only 3 weeks of moderate use. On Tuesday, I will be contacting JL to see if they will replace this product or refund my money. Wish me luck. After all, they should stand behind their product, especially when a customer receives a turd-sub with their name on it... and the words "#1 in Product Reliability" are written right on THE FRONT OF THE F^*KING BOX!




Last edited by Vertigo; 05-26-2012 at 08:02 PM.
Vertigo is offline   Reply With Quote
Old 05-26-2012, 08:46 PM   #2 (permalink)
Track Member
 
mhcoss's Avatar
 
Join Date: Feb 2012
Location: Edmonton
Posts: 520
Drives: 2012 370Z SPORT M/T
Rep Power: 10
mhcoss will become famous soon enough
Default

sux man
mhcoss is offline   Reply With Quote
Old 05-26-2012, 10:21 PM   #3 (permalink)
A True Z Fanatic
 
Vertigo's Avatar
 
Join Date: Dec 2011
Location: Philadelphia
Posts: 15,476
Drives: 370z / R32
Rep Power: 217
Vertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond repute
Send a message via AIM to Vertigo
Default

Is there anything else I could possibly try to see if this sub is 100% toast?
Vertigo is offline   Reply With Quote
Old 05-26-2012, 10:55 PM   #4 (permalink)
Track Member
 
mhcoss's Avatar
 
Join Date: Feb 2012
Location: Edmonton
Posts: 520
Drives: 2012 370Z SPORT M/T
Rep Power: 10
mhcoss will become famous soon enough
Default

you usin a 2 channel amp? I'm not sure how your sub is specifically wired but if your usin a 2 channel amp did you make sure that one channel in your amp isn't fried?
mhcoss is offline   Reply With Quote
Old 05-26-2012, 10:58 PM   #5 (permalink)
Base Member
 
Baconboy's Avatar
 
Join Date: Sep 2011
Location: Merrimack Valley, MA
Posts: 121
Drives: 40th '71chev '34ford
Rep Power: 10
Baconboy is on a distinguished road
Default

Did you buy from a reputable source?
Baconboy is offline   Reply With Quote
Old 05-26-2012, 10:59 PM   #6 (permalink)
A True Z Fanatic
 
Vertigo's Avatar
 
Join Date: Dec 2011
Location: Philadelphia
Posts: 15,476
Drives: 370z / R32
Rep Power: 217
Vertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond repute
Send a message via AIM to Vertigo
Default

It's not, I hooked the wires from the amp outlet that was powering the working sub to the nonworking sub, but still didn't get sound.
Vertigo is offline   Reply With Quote
Old 05-26-2012, 11:17 PM   #7 (permalink)
A True Z Fanatic
 
Vertigo's Avatar
 
Join Date: Dec 2011
Location: Philadelphia
Posts: 15,476
Drives: 370z / R32
Rep Power: 217
Vertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond repute
Send a message via AIM to Vertigo
Default

Quote:
Originally Posted by Baconboy View Post
Did you buy from a reputable source?

Yes, box was sealed and brand new for both subs. Both have never been used.
Vertigo is offline   Reply With Quote
Old 05-26-2012, 11:18 PM   #8 (permalink)
Base Member
 
Join Date: Jan 2012
Location: Charlotte, nc
Posts: 87
Drives: 07 Element SC
Rep Power: 10
BigNate is on a distinguished road
Default

Give them a break nobody is perfect....EVERY company has a defective product now and again....As long as you made the purchase through an authorized dealer which if purchased online is either crutchfield or shopatron thru jls website they will certainly replace your sub under warranty however if you paid $159 for a W3v3 I'm willing to bet you did not purchase from an authorized retailer and JL will not replace your sub because the warranty is void if not purchased authorized....in which case you should contact the seller instead of JL
__________________
MECP Master Certified Installation Technician

Don't worry I've never done this before
BigNate is offline   Reply With Quote
Old 05-26-2012, 11:21 PM   #9 (permalink)
Retired admin
 
frost's Avatar
 
Join Date: Dec 2008
Location: Winterfell
Posts: 106,613
Drives: Your Wife Crazy
Rep Power: 0
frost frost frost frost frost frost frost frost frost frost frost
Default

Quote:
Originally Posted by BigNate View Post
Give them a break nobody is perfect....
Kind of my thoughts. They mass produce stuff, it's impossible for any company to produce 100% perfect quality all the time.

That being said, the quality **** on the box of something that broke so quickly is pretty damn funny
__________________
370z OG

Quote:
Originally Posted by rooftop View Post
<insert snarky, slightly condescending frost joke>
frost is offline   Reply With Quote
Old 05-26-2012, 11:33 PM   #10 (permalink)
A True Z Fanatic
 
Vertigo's Avatar
 
Join Date: Dec 2011
Location: Philadelphia
Posts: 15,476
Drives: 370z / R32
Rep Power: 217
Vertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond repute
Send a message via AIM to Vertigo
Default

Quote:
Originally Posted by BigNate View Post
Give them a break nobody is perfect

I'm not saying JL is a sh!t company; I'm saying they made a dud that I bought and I hope they stand behind their dud and replace their dud.
Vertigo is offline   Reply With Quote
Old 05-27-2012, 12:21 AM   #11 (permalink)
Base Member
 
Join Date: Jan 2012
Location: Charlotte, nc
Posts: 87
Drives: 07 Element SC
Rep Power: 10
BigNate is on a distinguished road
Default

Where did you purchase this dud?
__________________
MECP Master Certified Installation Technician

Don't worry I've never done this before
BigNate is offline   Reply With Quote
Old 05-27-2012, 12:53 AM   #12 (permalink)
A True Z Fanatic
 
Vertigo's Avatar
 
Join Date: Dec 2011
Location: Philadelphia
Posts: 15,476
Drives: 370z / R32
Rep Power: 217
Vertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond reputeVertigo has a reputation beyond repute
Send a message via AIM to Vertigo
Default

SonicElectronix
Vertigo is offline   Reply With Quote
Old 05-27-2012, 02:09 AM   #13 (permalink)
Base Member
 
Join Date: Jan 2012
Location: Charlotte, nc
Posts: 87
Drives: 07 Element SC
Rep Power: 10
BigNate is on a distinguished road
Default

Then you need to call Sonic JLs website clearly states that any potential warranty is voided when the product is not purchased through an authorized dealer.
__________________
MECP Master Certified Installation Technician

Don't worry I've never done this before
BigNate is offline   Reply With Quote
Old 05-27-2012, 03:40 PM   #14 (permalink)
A True Z Fanatic
 
MacLean's Avatar
 
Join Date: Apr 2012
Location: Houston
Posts: 1,589
Drives: '12 GM Nismo # 0445
Rep Power: 12
MacLean has a spectacular aura aboutMacLean has a spectacular aura aboutMacLean has a spectacular aura about
Default

That sucks man. Sorry to hear the news.
MacLean is offline   Reply With Quote
Old 05-27-2012, 04:02 PM   #15 (permalink)
A True Z Fanatic
 
martin82's Avatar
 
Join Date: Nov 2011
Location: los angeles
Posts: 2,636
Drives: 12 Nissan 370Z MB M6
Rep Power: 16
martin82 has much to be proud ofmartin82 has much to be proud ofmartin82 has much to be proud ofmartin82 has much to be proud ofmartin82 has much to be proud ofmartin82 has much to be proud ofmartin82 has much to be proud ofmartin82 has much to be proud ofmartin82 has much to be proud of
Send a message via AIM to martin82
Default

You can check with a multimeter to see if ur voice coils are blown..... I have one wire desolder on the vc going to the sub before and had to reweld it myself.
martin82 is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[WTB] 220 shipped for your HFC harman.khinda Parts for sale (Private Classifieds) 2 02-28-2012 03:35 PM
[FOR SALE] 2010 Z Key Fob - $85 Shipped Jeffblue Parts for sale (Private Classifieds) 9 10-12-2011 10:14 PM
[FOR SALE] K&N Panel Filters ($75 shipped) | 370Z TPMS Sensors ($175 shipped) | SSR Plate Frame 370Z JT Parts for sale (Private Classifieds) 6 07-17-2011 10:29 AM


All times are GMT -5. The time now is 02:14 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 PL2