Nissan 370Z Forum  

Go Back   Nissan 370Z Forum > Members List

TBatt has a reputation beyond reputeTBatt has a reputation beyond reputeTBatt has a reputation beyond reputeTBatt has a reputation beyond reputeTBatt has a reputation beyond reputeTBatt has a reputation beyond reputeTBatt has a reputation beyond reputeTBatt has a reputation beyond reputeTBatt has a reputation beyond reputeTBatt has a reputation beyond reputeTBatt has a reputation beyond repute

TBatt TBatt is offline

Premium Member

Visitor Messages

Showing Visitor Messages 1 to 9 of 9
  1. DylansZ
    12-12-2022 11:31 PM - permalink
    DylansZ
    TBatt Wrote :
    Last night I found the problem. A connector was not fully seated on the transmission harness that has the hookups for the O2 sensors. There is a single wire connector that goes up near the starter motor that was not seated all of the way. When it was fixed the car started up.
    --------------------
    Sorry to bug you 6 years after you posted this - but i have having the same trouble (No recent work done to the car)
    I checked the switch with an ohm meter and checked the fuse and the only relay i could find in the IPDM.

    The wire you referred to .... where did it come from / Go to?
    Thanks Tons for any help you could offer.
    Dylan
  2. Dunciano
    09-27-2020 12:56 PM - permalink
    Dunciano
    PM’d you !
  3. YgoSlow
    03-07-2020 01:04 AM - permalink
    YgoSlow
    Crazy enough I'm in Huntsville and have been looking for a new (to me) car. I had test drove a Nismo up at Jerry Damson but it sold before I got the go ahead from my wife. I was wondering if you where available next week to meet up so that I can check out the 370. I'm Montgomery this weekend but will be back in Huntsville on Monday.

    -Edward
  4. TBatt
    11-12-2018 09:15 AM - permalink
    TBatt
    Sorry for the slow response but I've been crazy busy at work.

    Send via PayPal. My account is tbatt@knology.net
  5. Z4fun
    11-02-2018 10:35 AM - permalink
    Z4fun
    Sounds good where do I send the payment and shipping info too?
  6. TBatt
    10-12-2018 09:43 AM - permalink
    TBatt
    The complete kit, with shipping in the US is $175.
  7. Z4fun
    10-11-2018 08:58 AM - permalink
    Z4fun
    Hi ,
    How much do you charge for your stillen idler pulley and hd belt upgrade ?
  8. TBatt
    07-23-2016 05:14 PM - permalink
    TBatt
    Yes, but i don't have them with me at the moment, they are at my office.
  9. AGNTWOO
    07-23-2016 03:24 PM - permalink
    AGNTWOO
    Nice car- Roll Tide ('15)!

    Can you share your offsets?

About Me

  • About TBatt
    Biography
    motorhead
    Location
    Huntsville, AL
    Interests
    cars, RC planes
    Occupation
    engineer
    Drives
    2019 GT-R
  • Signature
    RJM pedal, Hotchkis Sway Bars, FI TDX, FOG Light, Z1 Slotted Drilled rotors, Stillen SC, Quaife ATB, Z1 Oil cooler, AEM Gauge Set, Galeforce gauge mount, Avant Garde M590 Hypersilver w/RE-11, TopgunZ A2A kit., ECUtek tuned by Seb: ROLL TIDE!

Statistics

Total Posts
Albums
Visitor Messages
General Information
  • Last Activity: 06-14-2021 01:34 PM
  • Join Date: 04-11-2013
  • Referrals: 0

Friends

Showing Friends 1 to 1 of 1

All times are GMT -5. The time now is 10:04 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 PL2