Nissan 370Z Forum  

Go Back   Nissan 370Z Forum > Members List

DeliriousClam has a reputation beyond reputeDeliriousClam has a reputation beyond reputeDeliriousClam has a reputation beyond reputeDeliriousClam has a reputation beyond reputeDeliriousClam has a reputation beyond reputeDeliriousClam has a reputation beyond reputeDeliriousClam has a reputation beyond reputeDeliriousClam has a reputation beyond reputeDeliriousClam has a reputation beyond reputeDeliriousClam has a reputation beyond reputeDeliriousClam has a reputation beyond repute

DeliriousClam DeliriousClam is offline

Premium Member

Visitor Messages

Showing Visitor Messages 1 to 1 of 1
  1. BoilardZ
    09-11-2017 11:16 PM - permalink
    BoilardZ
    Hi there. I just read your (year-old post) regarding loss of illumination in your steering wheel buttons, hazard and S mode switches, etc. How did that finally resolve itself? I've got the exact same problem, and I feel like it's GOT to be a fuse. Can't find anything blown, though. Maybe there's an in-line fuse? How did your issue get resolved? Any insights would be welcome! Steve

About Me

  • About DeliriousClam
    Location
    Greystone
    Drives
    full retard
  • Signature
    Stillen, AAM, Shine Auto, Fujimora, Swift, EVO-R, Carbon Fiber Element, Nitrous Outlet
    MECP Advanced: CEA26671
    Most of what I post here are artistic works of fiction and falsehood. Only a fool would take anything I post here as fact.

Statistics

Total Posts
Albums
Visitor Messages
General Information
  • Join Date: 05-14-2015
  • Referrals: 0

Friends

Showing Friends 1 to 5 of 5

All times are GMT -5. The time now is 08:25 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 PL2