Nissan 370Z Forum  

Car won't rev past 2.5k, idles above 1k.

Hey guys. Fully built bottom end and supercharged here. Techs are stumped. Weird thing keeps happening where the car won't rev past 2.5k and it idles just above 1k. I

Go Back   Nissan 370Z Forum > Tech Area > Engine & Drivetrain > Forced Induction

Like Tree5Likes

Reply
 
LinkBack Thread Tools Display Modes
Old 08-28-2020, 09:43 AM   #1 (permalink)
Base Member
 
Join Date: Feb 2012
Location: Irvine, CA
Posts: 169
Drives: 2009 G37S 6-MT
Rep Power: 9
WillVHR is on a distinguished road
Default Car won't rev past 2.5k, idles above 1k.

Hey guys. Fully built bottom end and supercharged here. Techs are stumped. Weird thing keeps happening where the car won't rev past 2.5k and it idles just above 1k. I looked around and saw one thread on it but it doesn't help. Any ideas? I have a 2010 manual G coupe. I replaced the ECU and the VVEL controller and the issue is still happening. ECU was an exact match (2010 manual coupe ecu).
WillVHR is offline   Reply With Quote
Old 08-30-2020, 07:22 PM   #2 (permalink)
Base Member
 
Join Date: Aug 2014
Location: Florida
Posts: 103
Drives: 2008 6MT G37
Rep Power: 7
xnick101 is on a distinguished road
Default

Have you tried talking to your tuner about this issue? It seems like it is in limp mode.
__________________
|Boosted Performance Turbo G37 Coupe|
xnick101 is offline   Reply With Quote
Old 08-30-2020, 07:53 PM   #3 (permalink)
Premium Member
 
Join Date: Jun 2016
Location: Massachusetts
Posts: 330
Drives: 07 350z Nismo #0363
Rep Power: 3360
NissanTracker has a reputation beyond reputeNissanTracker has a reputation beyond reputeNissanTracker has a reputation beyond reputeNissanTracker has a reputation beyond reputeNissanTracker has a reputation beyond reputeNissanTracker has a reputation beyond reputeNissanTracker has a reputation beyond reputeNissanTracker has a reputation beyond reputeNissanTracker has a reputation beyond reputeNissanTracker has a reputation beyond reputeNissanTracker has a reputation beyond repute
Default

I've run into this issue a couple times when I first started tuning the supercharger kit and when I went with Topgunz A-A setup. Goes into limp mode. The tuner should be solving this issue.
NissanTracker is offline   Reply With Quote
Old 08-31-2020, 09:51 AM   #4 (permalink)
Base Member
 
Join Date: Feb 2012
Location: Irvine, CA
Posts: 169
Drives: 2009 G37S 6-MT
Rep Power: 9
WillVHR is on a distinguished road
Default

Quote:
Originally Posted by NissanTracker View Post
I've run into this issue a couple times when I first started tuning the supercharger kit and when I went with Topgunz A-A setup. Goes into limp mode. The tuner should be solving this issue.
My tuner said to check the extension harnesses for the TBs and MAFs.
Optimiser likes this.
WillVHR is offline   Reply With Quote
Old 08-31-2020, 10:18 AM   #5 (permalink)
A True Z Fanatic
 
Join Date: Jun 2014
Location: Claxton, Ga
Posts: 9,018
Drives: 2013 Nismo 370z
Rep Power: 2049821
Spooler has a reputation beyond reputeSpooler has a reputation beyond reputeSpooler has a reputation beyond reputeSpooler has a reputation beyond reputeSpooler has a reputation beyond reputeSpooler has a reputation beyond reputeSpooler has a reputation beyond reputeSpooler has a reputation beyond reputeSpooler has a reputation beyond reputeSpooler has a reputation beyond reputeSpooler has a reputation beyond repute
Default

Quote:
Originally Posted by WillVHR View Post
My tuner said to check the extension harnesses for the TBs and MAFs.
Ah, so you have the Stillen Supercharger setup.
Spooler is offline   Reply With Quote
Old 08-31-2020, 10:49 PM   #6 (permalink)
Base Member
 
Join Date: Feb 2012
Location: Irvine, CA
Posts: 169
Drives: 2009 G37S 6-MT
Rep Power: 9
WillVHR is on a distinguished road
Default

Quote:
Originally Posted by Spooler View Post
Ah, so you have the Stillen Supercharger setup.
Yeah I listed all mods in OP.
WillVHR is offline   Reply With Quote
Old 09-01-2020, 02:20 AM   #7 (permalink)
Enthusiast Member
 
Optimiser's Avatar
 
Join Date: Mar 2013
Location: Australia
Posts: 365
Drives: 2012 Nissan 370Z MT
Rep Power: 6718
Optimiser has a reputation beyond reputeOptimiser has a reputation beyond reputeOptimiser has a reputation beyond reputeOptimiser has a reputation beyond reputeOptimiser has a reputation beyond reputeOptimiser has a reputation beyond reputeOptimiser has a reputation beyond reputeOptimiser has a reputation beyond reputeOptimiser has a reputation beyond reputeOptimiser has a reputation beyond reputeOptimiser has a reputation beyond repute
Default

Quote:
Originally Posted by WillVHR View Post
My tuner said to check the extension harnesses for the TBs and MAFs.
Yes!
My TB extension harness still gives me limp mode at random/unpredicable times and has for years now. Might be fine for 6 months then plays up 2 or 3 times in a shorter (days/weeks) succession.
I still don't believe there is a proper fix for this including replacing the ext harness with a newer (upgraded) one from Stillen. Very annoying and unsafe!
Optimiser is offline   Reply With Quote
Old 09-01-2020, 10:36 AM   #8 (permalink)
Base Member
 
Join Date: Feb 2012
Location: Irvine, CA
Posts: 169
Drives: 2009 G37S 6-MT
Rep Power: 9
WillVHR is on a distinguished road
Default

Quote:
Originally Posted by Optimiser View Post
Yes!
My TB extension harness still gives me limp mode at random/unpredicable times and has for years now. Might be fine for 6 months then plays up 2 or 3 times in a shorter (days/weeks) succession.
I still don't believe there is a proper fix for this including replacing the ext harness with a newer (upgraded) one from Stillen. Very annoying and unsafe!
Limp mode is where the car has almost zero throttle. That's not the symptom I'm having. I'm having a symptom where the car idles above 1k and won't rev past 2.5k.
Optimiser likes this.
WillVHR is offline   Reply With Quote
Old 09-01-2020, 11:00 AM   #9 (permalink)
Banned
 
JARblue's Avatar
 
Join Date: Mar 2011
Location: Austin, TX
Age: 39
Posts: 33,415
Drives: 2011 6MT 1998 M3/4/5
Rep Power: 2684430
JARblue has a reputation beyond reputeJARblue has a reputation beyond reputeJARblue has a reputation beyond reputeJARblue has a reputation beyond reputeJARblue has a reputation beyond reputeJARblue has a reputation beyond reputeJARblue has a reputation beyond reputeJARblue has a reputation beyond reputeJARblue has a reputation beyond reputeJARblue has a reputation beyond reputeJARblue has a reputation beyond repute
Default

Limp mode is a general condition where the computer reduces power of the engine. There are various causes. You might see revs limited to 5K RPMs or 3K RPMs or less depending on the cause.
__________________

2011 370Z 6MT Sport Gun Metallic | ARC | CJM | Ecutek | FI | Fujimura | R2C | SPL | Stillen | TWM | Z1 | ZSpeed |
JARblue is offline   Reply With Quote
Old 09-01-2020, 11:09 AM   #10 (permalink)
Base Member
 
Join Date: Feb 2012
Location: Irvine, CA
Posts: 169
Drives: 2009 G37S 6-MT
Rep Power: 9
WillVHR is on a distinguished road
Default

Quote:
Originally Posted by JARblue View Post
Limp mode is a general condition where the computer reduces power of the engine. There are various causes. You might see revs limited to 5K RPMs or 3K RPMs or less depending on the cause.
Right but it also makes the car rev super slow. That's not what I'm experiencing. My car revs at normal speed. It just caps at 2.5k and idles above 1k. In limp mode, the car revs really slow through every gear. That's not what I'm experiencing.
WillVHR is offline   Reply With Quote
Old 09-01-2020, 12:00 PM   #11 (permalink)
Banned
 
JARblue's Avatar
 
Join Date: Mar 2011
Location: Austin, TX
Age: 39
Posts: 33,415
Drives: 2011 6MT 1998 M3/4/5
Rep Power: 2684430
JARblue has a reputation beyond reputeJARblue has a reputation beyond reputeJARblue has a reputation beyond reputeJARblue has a reputation beyond reputeJARblue has a reputation beyond reputeJARblue has a reputation beyond reputeJARblue has a reputation beyond reputeJARblue has a reputation beyond reputeJARblue has a reputation beyond reputeJARblue has a reputation beyond reputeJARblue has a reputation beyond repute
Default

Quote:
Originally Posted by WillVHR View Post
Right but it also makes the car rev super slow.
Not true. I've had limp mode hit me on the track due to oil temps and limit me to 5K RPMs. Other than the rev limit reduction, there was no perceptible change in throttle input or driveability. There are various levels of limp mode - you are referring to a more extreme condition. But still a version of limp mode.
__________________

2011 370Z 6MT Sport Gun Metallic | ARC | CJM | Ecutek | FI | Fujimura | R2C | SPL | Stillen | TWM | Z1 | ZSpeed |
JARblue is offline   Reply With Quote
Old 09-01-2020, 08:18 PM   #12 (permalink)
A True Z Fanatic
 
Join Date: Apr 2009
Location: Bummerton
Posts: 1,481
Drives: MtB 09 370z
Rep Power: 14
Spec Jay will become famous soon enoughSpec Jay will become famous soon enough
Send a message via AIM to Spec Jay
Default

Engine codes?
__________________
"Saber! 09 Monterey Blue Boosted Performance v2.0
Instagram:@SpecJay
Spec Jay is offline   Reply With Quote
Old 09-01-2020, 11:37 PM   #13 (permalink)
Enthusiast Member
 
Optimiser's Avatar
 
Join Date: Mar 2013
Location: Australia
Posts: 365
Drives: 2012 Nissan 370Z MT
Rep Power: 6718
Optimiser has a reputation beyond reputeOptimiser has a reputation beyond reputeOptimiser has a reputation beyond reputeOptimiser has a reputation beyond reputeOptimiser has a reputation beyond reputeOptimiser has a reputation beyond reputeOptimiser has a reputation beyond reputeOptimiser has a reputation beyond reputeOptimiser has a reputation beyond reputeOptimiser has a reputation beyond reputeOptimiser has a reputation beyond repute
Default

Quote:
Originally Posted by WillVHR View Post
Limp mode is where the car has almost zero throttle. That's not the symptom I'm having. I'm having a symptom where the car idles above 1k and won't rev past 2.5k.
OK.
Optimiser is offline   Reply With Quote
Old 09-02-2020, 12:05 PM   #14 (permalink)
Base Member
 
Join Date: Feb 2012
Location: Irvine, CA
Posts: 169
Drives: 2009 G37S 6-MT
Rep Power: 9
WillVHR is on a distinguished road
Default

So I replaced the extension harness with a brand new one yesterday. So far so good. No issues at all. Drove the car for 10 minutes. Shop is going to drive the car for the next few days to make sure everything is good to go. Will post update if anything happens.
WillVHR is offline   Reply With Quote
Old 09-02-2020, 12:06 PM   #15 (permalink)
Base Member
 
Join Date: Feb 2012
Location: Irvine, CA
Posts: 169
Drives: 2009 G37S 6-MT
Rep Power: 9
WillVHR is on a distinguished road
Default

Quote:
Originally Posted by Spec Jay View Post
Engine codes?
No codes at all.
WillVHR is offline   Reply With Quote
Reply

Bookmarks

Tags
ew loves to bite down hard, leg too short, rev dumping, toilets are for dumping

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
I've posted in the past but... James512 New Forum Member 7 02-21-2020 01:50 AM
Help! Car Idles Rough, Won't Accelerate, Service Engine Soon Light Flashes, Code P300 NeoNz Engine & Drivetrain 20 12-17-2015 06:02 PM
Can't go past 2500 RPM! Help! Corona370z Nissan 370Z Warranty / Scheduled Maintenance / Servicing / Repairs 25 06-11-2014 10:45 PM
post your past z's. dirTy_shoeZ Other Vehicles 18 04-29-2011 11:53 AM
Got my Z this past Saturday gleonard New 370Z Owner 8 07-22-2009 11:28 PM


All times are GMT -5. The time now is 03:30 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 PL2