Nissan 370Z Forum  

370z roof won't move warning light on

Might consider the "Hard Top Option"

Go Back   Nissan 370Z Forum > Other 370Z Models > Nissan 370Z Roadster (Convertible)

Like Tree145Likes

Reply
 
LinkBack Thread Tools Display Modes
Old 02-11-2019, 08:35 AM   #106 (permalink)
Base Member
 
LennyK's Avatar
 
Join Date: May 2015
Location: Mountain Top
Posts: 246
Drives: 370Z Roadster 2010
Rep Power: 204
LennyK has a reputation beyond reputeLennyK has a reputation beyond reputeLennyK has a reputation beyond reputeLennyK has a reputation beyond reputeLennyK has a reputation beyond reputeLennyK has a reputation beyond reputeLennyK has a reputation beyond reputeLennyK has a reputation beyond reputeLennyK has a reputation beyond reputeLennyK has a reputation beyond reputeLennyK has a reputation beyond repute
Default

Might consider the "Hard Top Option"
__________________
* ROADSTER * TOURING * 2010 * PLATINUM * GRAPHITE *
* Z * NISSAN * 370Z * NISSAN * Z *
LennyK is offline   Reply With Quote
Old 02-14-2019, 03:32 AM   #107 (permalink)
Base Member
 
Join Date: Mar 2017
Location: Los Angeles, CA
Posts: 42
Drives: 10 370 RoadsterPW M6
Rep Power: 4
TJM370ZR is on a distinguished road
Default

Scottish Paul- Before giving a dime to the stealership go talk to Eric at "The Prestige Companies" in Anaheim. He is a top notch pro and has diagnosed/repaired issues with our tops on several occasions.

Tell him Tyler from Best Coast Auto sent you!!
bunk likes this.
TJM370ZR is offline   Reply With Quote
Old 02-14-2019, 12:59 PM   #108 (permalink)
A True Z Fanatic
 
bunk's Avatar
 
Join Date: Mar 2018
Location: Southern California
Posts: 3,988
Drives: 2010 370z Roadster
Rep Power: 2393904
bunk has a reputation beyond reputebunk has a reputation beyond reputebunk has a reputation beyond reputebunk has a reputation beyond reputebunk has a reputation beyond reputebunk has a reputation beyond reputebunk has a reputation beyond reputebunk has a reputation beyond reputebunk has a reputation beyond reputebunk has a reputation beyond reputebunk has a reputation beyond repute
Default

Quote:
Originally Posted by TJM370ZR View Post
Scottish Paul- Before giving a dime to the stealership go talk to Eric at "The Prestige Companies" in Anaheim. He is a top notch pro and has diagnosed/repaired issues with our tops on several occasions.

Tell him Tyler from Best Coast Auto sent you!!
Good to know about this place. Close to me to boot!
__________________
-Drop in K&N Filter -Invidia Gemini CBE -Z1 Oil Cooler -Swift Springs - EcuTek -Forgestar F14 -SPL Camber Links -Akebono BBK Upgrade -Z1 Premium SS Lines -SPL Diff Bushings -SPL FUCAs - BellRaceworks Diff Brace
bunk is offline   Reply With Quote
Old 03-04-2019, 04:14 PM   #109 (permalink)
Base Member
 
Join Date: Sep 2018
Location: Oklahoma
Posts: 3
Drives: 2010 370Z Roadster
Rep Power: 3
okie.marv is on a distinguished road
Default 2010 Roadster with 91K

Hi Everyone, I'm new to the forum and really need to tap into your collective body of knowledge and trouble shooting skills: The day before yesterday, I had the top down in the daytime with temperatures in the mid-forties. Came back from running errands, pulled in the driveway, hit the top button and nothing no warning lights, etc. Does the top system have fuses in the fuse box and could just have been the cold weather only since temps have drop this week. It has worked okay all through summer and fall until two days ago. Thanks in advance!
okie.marv is offline   Reply With Quote
Old 03-04-2019, 08:13 PM   #110 (permalink)
Base Member
 
Join Date: Sep 2016
Location: Ontario, Canada
Posts: 207
Drives: 2016 RDSTR TS 6spd
Rep Power: 7992
gbhrps has a reputation beyond reputegbhrps has a reputation beyond reputegbhrps has a reputation beyond reputegbhrps has a reputation beyond reputegbhrps has a reputation beyond reputegbhrps has a reputation beyond reputegbhrps has a reputation beyond reputegbhrps has a reputation beyond reputegbhrps has a reputation beyond reputegbhrps has a reputation beyond reputegbhrps has a reputation beyond repute
Default

okie.marv,

Two things:

The owner's manual says to not operate the roof if the temperature is below 40 degrees F, mainly because the hydraulic oil would be too thick at that temperature to operate the pump and top rams without doing damage.

The other one that the trunk MUST be latched down correctly for the top to operate.

If those two parameters are met, the top should operate correctly, provided that you don't have any other issue.

The age of your car would make me guess that you have a broken wire in the wiring harness where the convertible top frame hinge areas are. Years of flexing may have broken one or more of the thin wires, particularly if the wires were cold.

Get back to us if you can't solve the issue. Good Luck!
sx moneypit, Spoiler and okie.marv like this.
gbhrps is offline   Reply With Quote
Old 03-04-2019, 08:56 PM   #111 (permalink)
A True Z Fanatic
 
bunk's Avatar
 
Join Date: Mar 2018
Location: Southern California
Posts: 3,988
Drives: 2010 370z Roadster
Rep Power: 2393904
bunk has a reputation beyond reputebunk has a reputation beyond reputebunk has a reputation beyond reputebunk has a reputation beyond reputebunk has a reputation beyond reputebunk has a reputation beyond reputebunk has a reputation beyond reputebunk has a reputation beyond reputebunk has a reputation beyond reputebunk has a reputation beyond reputebunk has a reputation beyond repute
Default

Quote:
Originally Posted by okie.marv View Post
Hi Everyone, I'm new to the forum and really need to tap into your collective body of knowledge and trouble shooting skills: The day before yesterday, I had the top down in the daytime with temperatures in the mid-forties. Came back from running errands, pulled in the driveway, hit the top button and nothing no warning lights, etc. Does the top system have fuses in the fuse box and could just have been the cold weather only since temps have drop this week. It has worked okay all through summer and fall until two days ago. Thanks in advance!
Were both windows rolled down when you tried to put the top back up? If so, roll the windows up. It doesnt have to be all the up nor both windows, just one window partially up is fine.
Ive had this happen to me before. It happened both opening and closing the top. It might be a window reset issue.
Spoiler, Rodd and okie.marv like this.
__________________
-Drop in K&N Filter -Invidia Gemini CBE -Z1 Oil Cooler -Swift Springs - EcuTek -Forgestar F14 -SPL Camber Links -Akebono BBK Upgrade -Z1 Premium SS Lines -SPL Diff Bushings -SPL FUCAs - BellRaceworks Diff Brace
bunk is offline   Reply With Quote
Old 03-07-2019, 03:36 PM   #112 (permalink)
Base Member
 
Join Date: Sep 2018
Location: Oklahoma
Posts: 3
Drives: 2010 370Z Roadster
Rep Power: 3
okie.marv is on a distinguished road
Default

Dear Bunk -- You just made my day! Rolled the windows back up and hit the close button and it worked like Perfectly. Thank you for taking the time as well as other members who contributed.
Spoiler and bunk like this.
okie.marv is offline   Reply With Quote
Old 03-07-2019, 09:42 PM   #113 (permalink)
Base Member
 
Join Date: Sep 2016
Location: Ontario, Canada
Posts: 207
Drives: 2016 RDSTR TS 6spd
Rep Power: 7992
gbhrps has a reputation beyond reputegbhrps has a reputation beyond reputegbhrps has a reputation beyond reputegbhrps has a reputation beyond reputegbhrps has a reputation beyond reputegbhrps has a reputation beyond reputegbhrps has a reputation beyond reputegbhrps has a reputation beyond reputegbhrps has a reputation beyond reputegbhrps has a reputation beyond reputegbhrps has a reputation beyond repute
Default

What??????!!!!!!!! That makes no sense whatsoever!

When the top is up, and the windows are closed, ..... the first thing that occurrs when you press the button to open the roof, is the windows power down! So why would your car have to have one window partially or all of the way up in order to get the system to close the top????!!!!

Baffling!!! But if it works ... why not?

Strange!
gbhrps is offline   Reply With Quote
Old 03-07-2019, 10:14 PM   #114 (permalink)
A True Z Fanatic
 
bunk's Avatar
 
Join Date: Mar 2018
Location: Southern California
Posts: 3,988
Drives: 2010 370z Roadster
Rep Power: 2393904
bunk has a reputation beyond reputebunk has a reputation beyond reputebunk has a reputation beyond reputebunk has a reputation beyond reputebunk has a reputation beyond reputebunk has a reputation beyond reputebunk has a reputation beyond reputebunk has a reputation beyond reputebunk has a reputation beyond reputebunk has a reputation beyond reputebunk has a reputation beyond repute
Default

Quote:
Originally Posted by gbhrps View Post
What??????!!!!!!!! That makes no sense whatsoever!

When the top is up, and the windows are closed, ..... the first thing that occurrs when you press the button to open the roof, is the windows power down! So why would your car have to have one window partially or all of the way up in order to get the system to close the top????!!!!

Baffling!!! But if it works ... why not?

Strange!
Right, Im assuming that the top system isnt detecting the windows rolling down, so it does nothing, if in fact the windows are all the way down.

..rolling the windows up gives what ever sensors involved something to do so it goes with the whole sequence...
I havent had time to really troubleshoot it. Ive been just living with making sure the windows are at least partially up before opening or closing the top. Like I said, it could just be a window reset, or a sensor. I havent looked at the schematics so I dont know how the top works..... yet..
__________________
-Drop in K&N Filter -Invidia Gemini CBE -Z1 Oil Cooler -Swift Springs - EcuTek -Forgestar F14 -SPL Camber Links -Akebono BBK Upgrade -Z1 Premium SS Lines -SPL Diff Bushings -SPL FUCAs - BellRaceworks Diff Brace
bunk is offline   Reply With Quote
Old 03-07-2019, 10:16 PM   #115 (permalink)
A True Z Fanatic
 
bunk's Avatar
 
Join Date: Mar 2018
Location: Southern California
Posts: 3,988
Drives: 2010 370z Roadster
Rep Power: 2393904
bunk has a reputation beyond reputebunk has a reputation beyond reputebunk has a reputation beyond reputebunk has a reputation beyond reputebunk has a reputation beyond reputebunk has a reputation beyond reputebunk has a reputation beyond reputebunk has a reputation beyond reputebunk has a reputation beyond reputebunk has a reputation beyond reputebunk has a reputation beyond repute
Default

Quote:
Originally Posted by okie.marv View Post
Dear Bunk -- You just made my day! Rolled the windows back up and hit the close button and it worked like Perfectly. Thank you for taking the time as well as other members who contributed.
Im glad it worked for you! Im sure theres still an underlying issue. Ill find some time to troublshoot it one of these days. If you find the issue before anyone else, feel free to post it!
Spoiler likes this.
__________________
-Drop in K&N Filter -Invidia Gemini CBE -Z1 Oil Cooler -Swift Springs - EcuTek -Forgestar F14 -SPL Camber Links -Akebono BBK Upgrade -Z1 Premium SS Lines -SPL Diff Bushings -SPL FUCAs - BellRaceworks Diff Brace
bunk is offline   Reply With Quote
Old 03-08-2019, 04:09 AM   #116 (permalink)
Bacon Connoisseur
 
Spoiler's Avatar
 
Join Date: Jun 2015
Location: Central Florida
Age: 37
Posts: 7,908
Drives: 2015 Roadster
Rep Power: 2684375
Spoiler has a reputation beyond reputeSpoiler has a reputation beyond reputeSpoiler has a reputation beyond reputeSpoiler has a reputation beyond reputeSpoiler has a reputation beyond reputeSpoiler has a reputation beyond reputeSpoiler has a reputation beyond reputeSpoiler has a reputation beyond reputeSpoiler has a reputation beyond reputeSpoiler has a reputation beyond reputeSpoiler has a reputation beyond repute
Default

Nice work Bunk...Glad Marv’s top is working again..

Kudos

-Spoiler
bunk likes this.
Spoiler is offline   Reply With Quote
Old 03-16-2019, 07:44 AM   #117 (permalink)
A True Z Fanatic
 
bunk's Avatar
 
Join Date: Mar 2018
Location: Southern California
Posts: 3,988
Drives: 2010 370z Roadster
Rep Power: 2393904
bunk has a reputation beyond reputebunk has a reputation beyond reputebunk has a reputation beyond reputebunk has a reputation beyond reputebunk has a reputation beyond reputebunk has a reputation beyond reputebunk has a reputation beyond reputebunk has a reputation beyond reputebunk has a reputation beyond reputebunk has a reputation beyond reputebunk has a reputation beyond repute
Default

FYI, I did a window reset. Top opens and closes fine with the windows rolled down.
Spoiler likes this.
__________________
-Drop in K&N Filter -Invidia Gemini CBE -Z1 Oil Cooler -Swift Springs - EcuTek -Forgestar F14 -SPL Camber Links -Akebono BBK Upgrade -Z1 Premium SS Lines -SPL Diff Bushings -SPL FUCAs - BellRaceworks Diff Brace
bunk is offline   Reply With Quote
Old 04-20-2019, 08:12 PM   #118 (permalink)
Base Member
 
Join Date: Nov 2018
Location: Nova Scotia
Posts: 5
Drives: 2010 370z roadster
Rep Power: 3
mikeshay is on a distinguished road
Default

Drives: 2010 370z roadster
Rep Power: 1
mikeshay is on a distinguished road
Default
I have a 2010 I bought new , never had any top problems until late last summer the lid hit the roof bow a couple times then one time I heard a loud snap roof wouldn't close, ran it to the dealer , one of the frame brackets had broke free, no fix 12gran for a new roof, 3rd one they had seen like that last summer all 2010s now I have a convertible that is totally useless looks like I'm going to get a hardtop for it cars not worth putting 12g into plus labour to install it
vman12 likes this.
mikeshay is offline   Reply With Quote
Old 03-26-2020, 04:04 PM   #119 (permalink)
Base Member
 
Join Date: Dec 2016
Location: Houston, TX
Posts: 4
Drives: 2010 370z RdsterTour
Rep Power: 4
Cryogenius is on a distinguished road
Default Soft Top DIY Repair Success

I had the usual symptom of a light on the dash and alarm when trying to drive.

One great resource I found on trying to solve this problem is on YouTube. TopHydraulics has made 10 videos explaining every component in the system and how to access them for maintenance. With this information and a shop manual you can, with patience and a pure mind, figure out what is wrong. If the problem is with the hydraulics, TopHydraulics can sell you a better and cheaper component than the dealer.

In my case, following the procedure of TopHydraulics Chapter 9, I was measuring 0.8 volts or 3.0 volts on all of the sensors (all voltages are based on roof position) and they were all correct, with one exception. That exception was the 5th bow striker sensor that was measuring only 0.1 volt. Note: there is a metal bracket that holds the control unit and I had to pull the unit out of that bracket to make the measurements. The unit just slides into the bracket without fasteners and with the right motion you can pull it out with all the wires attached for easier access.

Elsewhere in this discussion there is a photo of the wire harness that runs back to the storage lid where the sensor is located. It is on the driver's side and it is in contact with the 5th bow by (bad?) design. This is where my problem was and based on my reading it is a common problem. Within the wiring harness the wire had either fatigued or been abraded by the mechanism. Strangely enough I had measured a voltage reading but the wire broke completely as I was unwrapping it.

I really had to unwrap a lot of the harness to get to the problem, so I recommend perseverance on examination of the harness. Klaus asked me if I had actually unwrapped enough of the harness and it is a good thing he did.

I have included a photo of my re-wrapped harness for reference. I spliced in a wire and used heat shrink wrap followed by electrical tape. For the wire I used to do the splicing I tried to find a wire with the same copper and flexibility to avoid stress concentration where the two wires meet; if one wire is stiffer then the softer wire will eventually fatigue. I did solder the connection, so maybe I created a stress problem for myself. If this fails again I may try a connector.

The next time this happens I will just check the harness - this is relatively easy. Only if I see nothing will I get into the sensor voltage measurements.

Cryogenius is offline   Reply With Quote
Old 03-26-2020, 07:34 PM   #120 (permalink)
Base Member
 
Join Date: Sep 2016
Location: Ontario, Canada
Posts: 207
Drives: 2016 RDSTR TS 6spd
Rep Power: 7992
gbhrps has a reputation beyond reputegbhrps has a reputation beyond reputegbhrps has a reputation beyond reputegbhrps has a reputation beyond reputegbhrps has a reputation beyond reputegbhrps has a reputation beyond reputegbhrps has a reputation beyond reputegbhrps has a reputation beyond reputegbhrps has a reputation beyond reputegbhrps has a reputation beyond reputegbhrps has a reputation beyond repute
Default

Cryogenius,

Thanks for the update!

Great to know that Klaus's videos are getting results, and that there are some of us with enough automotive/electrical DIY knowledge, who are able to tackle these top issues and then help the rest of us out.

Can you share that picture with us and then point out where the wiring fatigue break was? It'll certainly help someone here to see where they need to start digging if they have a similar situation as yours.

Thanks!

Gene
gbhrps is offline   Reply With Quote
Reply

Bookmarks

Tags
roadster, roof, stuck, top issue, warning indicator

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
WARNING! You may get stranded if you see this light. Minicobra1 Nissan 370Z Warranty / Scheduled Maintenance / Servicing / Repairs 18 06-19-2019 05:09 PM
Key warning light picture? plato Nissan 370Z General Discussions 9 03-03-2014 05:06 PM
Hood warning light need help Loki Engine & Drivetrain 0 03-28-2012 10:46 AM
tail light out warning light cossie1600 Exterior & Interior 0 06-28-2011 09:15 PM
Ikey warning light X90DAV Nissan 370Z General Discussions 4 04-25-2010 09:50 PM


All times are GMT -5. The time now is 05:24 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 PL2