Nissan 370Z Forum  

370z roof won't move warning light on

Originally Posted by marksta yes it does.. Once the top moves it acts like normal.. plan ti checking the wiring today. any other suggestions is appreciated.. my local nissan dealer

Go Back   Nissan 370Z Forum > Other 370Z Models > Nissan 370Z Roadster (Convertible)

Like Tree147Likes

Reply
 
LinkBack Thread Tools Display Modes
Old 10-11-2020, 08:58 PM   #136 (permalink)
we rep we post we drive
 
alcheng's Avatar
 
Join Date: Jun 2011
Location: Toronto
Posts: 28,852
Drives: 2011 ZR PW w/Clutch
Rep Power: 418333
alcheng has a reputation beyond reputealcheng has a reputation beyond reputealcheng has a reputation beyond reputealcheng has a reputation beyond reputealcheng has a reputation beyond reputealcheng has a reputation beyond reputealcheng has a reputation beyond reputealcheng has a reputation beyond reputealcheng has a reputation beyond reputealcheng has a reputation beyond reputealcheng has a reputation beyond repute
Default

Quote:
Originally Posted by marksta View Post
yes it does.. Once the top moves it acts like normal.. plan ti checking the wiring today. any other suggestions is appreciated.. my local nissan dealer is worthless

similar thing happened to mine couple years ago, yhe top can open no problem at all.

only when it is closing, the front latch onto the windshield frame no problem but cannot complete the latching at the back.

found the it's the faulty sensor at the top-storage.
marksta likes this.
alcheng is offline   Reply With Quote
Old 10-20-2020, 05:10 PM   #137 (permalink)
Base Member
 
Join Date: Jul 2014
Location: Florence, ky
Posts: 5
Drives: 2010-370z-blue= aut
Rep Power: 7
marksta is on a distinguished road
Default

FIXED. Thanks to Top Hydraulics for their advice to reset the system AFTER I repaired the wire harness going to the hatch assembly. They told me to remove the common from the battery for 2 hours, cycle the windows than try the top- it worked!!!
gr8-wrx and Spoiler like this.
marksta is offline   Reply With Quote
Old 11-03-2020, 09:49 PM   #138 (permalink)
Base Member
 
13overpar's Avatar
 
Join Date: Oct 2019
Location: FL
Posts: 10
Drives: 2013 370z touring
Rep Power: 2
13overpar is on a distinguished road
Default

I'm having the same issue, the hydraulic pump was recently replaced I've also tried disconnecting the battery. The rear bow will not engage. Top Hydraulics is also helping me trouble shoot this issue.
Spoiler likes this.
13overpar is offline   Reply With Quote
Old 12-04-2020, 09:46 PM   #139 (permalink)
Enthusiast Member
 
10MPlayer's Avatar
 
Join Date: May 2013
Location: Sacratomato
Posts: 302
Drives: your mama wild.
Rep Power: 9
10MPlayer has much to be proud of10MPlayer has much to be proud of10MPlayer has much to be proud of10MPlayer has much to be proud of10MPlayer has much to be proud of10MPlayer has much to be proud of10MPlayer has much to be proud of10MPlayer has much to be proud of10MPlayer has much to be proud of
Default

Check the hydraulic fluid level. Check for hydraulic leaks. If the fluid level is low or if there is air in the system it won't work completely. Klaus at Top Hydraulics told me the system is self-bleeding, which means it will bleed any air in the system automatically, but if there's not enough fluid in the system (from a fluid leak) it will only go so far then quit. I accidentally nicked a hydraulic line causing a leak. The top would only go so far then quit. I replaced the lines and filled it with new fluid. It works now.
Spoiler likes this.
__________________
About my name: I occasionally play a Conn 10M Tenor Saxophone - so 10MPlayer
10MPlayer is offline   Reply With Quote
Old 03-20-2021, 05:39 PM   #140 (permalink)
Base Member
 
Join Date: Dec 2016
Location: Houston, TX
Posts: 7
Drives: 2010 370z RdsterTour
Rep Power: 5
Cryogenius is on a distinguished road
Default

Hello gang, I am back at it with a new set of symptoms on my 2010 roadstar. Here are the details:

1) Soft top has been in storage (top down, or open) for about a month. I start engine, no warning lights and all seems good until...
2) I hit the CLOSE button. The storage lid opens about an inch and gives up. Roof open light stays on. The lid drops back down due to gravity but the light stays on.
3) I hit the OPEN button. The motors turn and the lid closes completely. Roof open light goes out and all seems good.
4) I repeat the process again with the same results.
5) I manually raise the roof halfway, start the car and hit the CLOSE button. The soft top closes and latches as it should, and the roof open light goes out - no warnings.

I have not tried to open and close the top again. I do notice that the soft top is hitting and pulling down the storage compartment cover when it opens - which I believe is a sign of weak bungees. I have heard of the top not opening when the bungees are weak, but have not found anyone with difficulties getting the top to close.

I saw no sign of hydraulic fluid leaks in the storage compartment.

Question: Would weak bungees cause the top to rise only an inch or two and then give up? Has anyone else experienced this problem and solved it with new bungees. I need to replace them anyway, but I still wonder if that is the problem. I think I am good on the electrical because the top can be hydraulically latched open or closed without roof open warning lights at the end of travel.
Cryogenius is offline   Reply With Quote
Old 03-25-2021, 09:59 AM   #141 (permalink)
Base Member
 
Join Date: Dec 2016
Location: Houston, TX
Posts: 7
Drives: 2010 370z RdsterTour
Rep Power: 5
Cryogenius is on a distinguished road
Default More on Bungees

I am trying to replace the fifth bow bungees, and this is a story unto itself.

Part numbers 971F8-1ET0A and 971F9-1ET0A for the bungees on each side is discontinued and replaced by the 971F8-1ET0B kit. However, the 971F8-1ET0B kit is discontinued and replaced by the 971F6-1ET0A kit. That is available by special order from my dealer parts (delivery in one day) for $233.

The same part seems to be available on [URL="https://frsport.com/search?q=971F6-1ET0A"] for $157 plus shipping(?). Anyway, the soft top bungee saga continues.
gr8-wrx likes this.
Cryogenius is offline   Reply With Quote
Old 03-28-2021, 10:05 AM   #142 (permalink)
Base Member
 
Join Date: Nov 2018
Location: Treasure Coast, FL
Posts: 15
Drives: Pearl 370z Roadster
Rep Power: 3
6SpeedZ is on a distinguished road
Default I've read through each post/comment ... still need help!

Brought my Z to a few shops now "pro's & Nissan master techs).
Now that the open/close button has power again my top will open (I have the use the tool to unlatch it from the windshield manually) the top will open all the way and BEEP once done.

However, when I press the button to close the top, it closes all the way, locks in the back, but it does not beep. The second that I let go of the button the top unlocks just in the front and pops back up immediately. I then will have to shut off the car and use the tool to close/lock it to the front.

*If you have an idea on how to reattach the defrost wire to the rear window that would also be great!

Thank you in advance ...
6SpeedZ is offline   Reply With Quote
Old 04-05-2021, 04:40 PM   #143 (permalink)
Base Member
 
Join Date: Dec 2016
Location: Houston, TX
Posts: 7
Drives: 2010 370z RdsterTour
Rep Power: 5
Cryogenius is on a distinguished road
Default Update on soft top malfunction

Quote:
Originally Posted by Cryogenius View Post
Hello gang, I am back at it with a new set of symptoms on my 2010 roadstar. Here are the details:

1) Soft top has been in storage (top down, or open) for about a month. I start engine, no warning lights and all seems good until...
2) I hit the CLOSE button. The storage lid opens about an inch and gives up. Roof open light stays on. The lid drops back down due to gravity but the light stays on.
3) I hit the OPEN button. The motors turn and the lid closes completely. Roof open light goes out and all seems good.
4) I repeat the process again with the same results.
5) I manually raise the roof halfway, start the car and hit the CLOSE button. The soft top closes and latches as it should, and the roof open light goes out - no warnings.

I have not tried to open and close the top again. I do notice that the soft top is hitting and pulling down the storage compartment cover when it opens - which I believe is a sign of weak bungees. I have heard of the top not opening when the bungees are weak, but have not found anyone with difficulties getting the top to close.

I saw no sign of hydraulic fluid leaks in the storage compartment.

Question: Would weak bungees cause the top to rise only an inch or two and then give up? Has anyone else experienced this problem and solved it with new bungees. I need to replace them anyway, but I still wonder if that is the problem. I think I am good on the electrical because the top can be hydraulically latched open or closed without roof open warning lights at the end of travel.
Update: I went through the sensor diagnostic procedure given by Top Hydraulics on their YouTube video, and found that once again I had a broken wire which I had previously repaired. Symptoms different this time, but it was the number 76 connection again (5th bow striker sensor). Top now works but I still may take on the bungee replacement as a preemptive measure.

Update No. 2: Started the bungee replacement procedure but chickened out when I got to the "cut old bungee cords out" step. They all seemed to be in good enough condition and there was no way to recover once they were cut other than to muddle through the remaining 5 or 6 hours of work (per SIDE) if I could even figure it all out. I put it back together and the top would not open because the fifth bow was hitting the back lip of the storage compartment. It looked as though the lid was about 1/4 - 1/2 inch proud of the compartment edge and therefore would not go in. I did more research and found that there is a known problem of a pin coming out of a drag link channel, and the channel needs to be opened back up (NTB14-064). This took about 3 minutes to accomplish once I saw that this was indeed the problem on both sides (note: 3 minutes does not include the manual opening of the soft top because I had already done that). Hint: I used a large screwdriver with a square shaft and put vise-grips on the shaft for more torque. Be careful! The metal you are bending is relatively soft and does not need THAT much encouragement. Top now working again. Here is the file on the Nissan Technical Service Bulletin, and a illustration that I did showing before and after.

https://f01.justanswer.com/05muranos...4-064_370z.pdf
https://flic.kr/p/2kSmzWD

Last edited by Cryogenius; 04-11-2021 at 01:40 PM. Reason: update on diagnosis and repair
Cryogenius is offline   Reply With Quote
Reply

Bookmarks

Tags
roadster, roof, stuck, top issue, warning indicator

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
WARNING! You may get stranded if you see this light. Minicobra1 Nissan 370Z Warranty / Scheduled Maintenance / Servicing / Repairs 18 06-19-2019 04:09 PM
Key warning light picture? plato Nissan 370Z General Discussions 9 03-03-2014 04:06 PM
Hood warning light need help Loki Engine & Drivetrain 0 03-28-2012 09:46 AM
tail light out warning light cossie1600 Exterior & Interior 0 06-28-2011 08:15 PM
Ikey warning light X90DAV Nissan 370Z General Discussions 4 04-25-2010 08:50 PM


All times are GMT -5. The time now is 10:19 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 PL2