Nissan 370Z Forum  

Hfc install problem

Does a hfc need time to break in or something? I just removed my test pipes and installed my z1 hfc yesterday and Iím getting a weird sound. Nothing was

Go Back   Nissan 370Z Forum > Tech Area > Engine & Drivetrain > Intake/Exhaust

Reply
 
LinkBack Thread Tools Display Modes
Old 01-16-2018, 04:10 PM   #1 (permalink)
Base Member
 
Join Date: Feb 2017
Location: Omaha
Posts: 67
Drives: 370z base
Rep Power: 1
Fhjkalfhu is on a distinguished road
Default Hfc install problem

Does a hfc need time to break in or something? I just removed my test pipes and installed my z1 hfc yesterday and Iím getting a weird sound. Nothing was present until this morning. I checked yesterday and there was no sound after the install.


Ticking from the engine bay and this from under the car.

https://youtu.be/8Y1yLqabX1I
Fhjkalfhu is offline   Reply With Quote
Old 01-16-2018, 04:35 PM   #2 (permalink)
Base Member
 
Join Date: Nov 2016
Location: Youngstown, FL
Posts: 93
Drives: to be determined...
Rep Power: 2
bcfromfl is on a distinguished road
Default

I did a bit of Googling about this a while back, and found this install procedure: Cats with Superchargers
bcfromfl is offline   Reply With Quote
Old 01-16-2018, 10:48 PM   #3 (permalink)
Base Member
 
Join Date: Feb 2017
Location: Omaha
Posts: 67
Drives: 370z base
Rep Power: 1
Fhjkalfhu is on a distinguished road
Default

Yea my stupid self forgot to tighten the extra sensor bung cap before the cat...
Fhjkalfhu is offline   Reply With Quote
Old 01-17-2018, 03:40 AM   #4 (permalink)
Track Member
 
NISMO IX's Avatar
 
Join Date: Sep 2015
Location: Southern Maine
Age: 40
Posts: 619
Drives: 2014 370Z MB M6
Rep Power: 4
NISMO IX is on a distinguished road
Default

Yeah, that would do it
__________________
2014 370z Mag Blk 6M "KOKURYU" (Black Dragon)
2014 Juke NISMO Brilliant Silver AWD/CVT "NISMO IX"
2011 Juke S AWD / 2006 SE-R Spec-V (traded)
NISMO IX is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Z1 2 piece install problem Sway Brakes & Suspension 8 11-18-2017 05:20 PM
FI TP install problem help persiani Engine & Drivetrain 5 08-25-2012 11:11 PM
K&N Typhoon Install problem VaGntlmn Intake/Exhaust 55 06-26-2012 05:23 PM
Tune or install problem? EVOHUNTER Tuning 11 05-23-2012 07:41 PM
Coilover install problem sig11 Brakes & Suspension 16 03-29-2012 08:01 AM


All times are GMT -5. The time now is 06:00 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 PL2