Nissan 370Z Forum  

cruise control on dash blinking?!?

Originally Posted by Lunar-Eclipse I'm not the OP but a few months after Nissan replaced my ECM I started getting the damn blinking light again. After much troubleshooting I figured

Go Back   Nissan 370Z Forum > Nissan 370Z Tech Area > Exterior & Interior

Like Tree9Likes

Reply
 
LinkBack Thread Tools Display Modes
Old 07-27-2015, 05:21 PM   #31 (permalink)
Enthusiast Member
 
Kabestro's Avatar
 
Join Date: Aug 2012
Location: Puerto Rico
Posts: 331
Drives: 13 Nissan 370Z MR M6
Rep Power: 37
Kabestro has a reputation beyond reputeKabestro has a reputation beyond reputeKabestro has a reputation beyond reputeKabestro has a reputation beyond reputeKabestro has a reputation beyond reputeKabestro has a reputation beyond reputeKabestro has a reputation beyond reputeKabestro has a reputation beyond reputeKabestro has a reputation beyond reputeKabestro has a reputation beyond reputeKabestro has a reputation beyond repute
Default

Quote:
Originally Posted by Lunar-Eclipse View Post
I'm not the OP but a few months after Nissan replaced my ECM I started getting the damn blinking light again. After much troubleshooting I figured out the problem was the contacts on the clutch safety switch. I cleaned them as a temporary fix but I ultimately replaced the switch. It was a whole $16 from the dealer. That was a year ago. No blinking light since.
I'm having this problem also, were exactly are those contacts on the clutch safety switch? Pics?
Ellie_Zee34 likes this.
__________________
Stillen Gen 3 CAI / Fast Intentions HFC and CBE 12" Res. (#730) / Swift Springs / 20mm H&R Spacers / Clutch Helper Spring / UpRev Tune 322whp.
Kabestro is offline   Reply With Quote
Old 07-27-2015, 10:59 PM   #32 (permalink)
Base Member
 
Lunar-Eclipse's Avatar
 
Join Date: May 2011
Location: Florida
Posts: 125
Drives: '10 40th Anniversary
Rep Power: 11
Lunar-Eclipse is on a distinguished road
Default

The contacts are in the safety switch. I don't have pictures and I tossed the bad switch long ago. But I did find pictures of a 350z safety switch. It looks the same as the 370z switch. Be careful opening it, the tabs are very fragile. I broke one while taking it apart. Glued it back on. Once apart I used some rubbing alcohol on a q-tip to clean the contacts.
Clutch Safety Switch-Cleaning & Adjust - MY350Z.COM Forums
Kabestro likes this.
Lunar-Eclipse is offline   Reply With Quote
Old 07-28-2015, 08:04 PM   #33 (permalink)
Enthusiast Member
 
Kabestro's Avatar
 
Join Date: Aug 2012
Location: Puerto Rico
Posts: 331
Drives: 13 Nissan 370Z MR M6
Rep Power: 37
Kabestro has a reputation beyond reputeKabestro has a reputation beyond reputeKabestro has a reputation beyond reputeKabestro has a reputation beyond reputeKabestro has a reputation beyond reputeKabestro has a reputation beyond reputeKabestro has a reputation beyond reputeKabestro has a reputation beyond reputeKabestro has a reputation beyond reputeKabestro has a reputation beyond reputeKabestro has a reputation beyond repute
Default

Thanks man!!
__________________
Stillen Gen 3 CAI / Fast Intentions HFC and CBE 12" Res. (#730) / Swift Springs / 20mm H&R Spacers / Clutch Helper Spring / UpRev Tune 322whp.
Kabestro is offline   Reply With Quote
Old 12-03-2016, 02:29 PM   #34 (permalink)
Base Member
 
Join Date: Oct 2015
Location: San Jose, CA
Posts: 10
Drives: 14 BrSi 370z T/S/7A
Rep Power: 6
Mr Chow is on a distinguished road
Default

6 weeks ago the cruise control light would flash randomly. Thanks to this thread I did not worry. Took it into the dealer yesterday. The repair tech wrote he ran "data monitor" which found the ASCD switch defective. He replaced the Switch Assy-ASCD p/n 25300-62J0E located on the brake pedal, retested and the switch is working properly. Keeping my fingers crossed. If the cruise light doesn't flash in a couple weeks all is good.
Thank you to OP.
Memphis370Z and Ellie_Zee34 like this.
Mr Chow is offline   Reply With Quote
Old 05-10-2020, 12:34 PM   #35 (permalink)
Base Member
 
Gungrave's Avatar
 
Join Date: Jul 2010
Location: Brandon, FL
Posts: 129
Drives: 2010 370Z
Rep Power: 1161
Gungrave has a reputation beyond reputeGungrave has a reputation beyond reputeGungrave has a reputation beyond reputeGungrave has a reputation beyond reputeGungrave has a reputation beyond reputeGungrave has a reputation beyond reputeGungrave has a reputation beyond reputeGungrave has a reputation beyond reputeGungrave has a reputation beyond reputeGungrave has a reputation beyond reputeGungrave has a reputation beyond repute
Default

I know I’m bumping an old thread, but we’re any of you guys able to confirm the issue with this? My cruise control light started blinking the other day out of nowhere and I have no clue why. I’ll be driving the car probably later today to see if it does it again and I’ll be checking for scans and monitor the coolant temperature, but also wanted to make sure if you guys knew what the actual problem was.
Gungrave is offline   Reply With Quote
Old 05-10-2020, 02:11 PM   #36 (permalink)
Track Member
 
Tractionless's Avatar
 
Join Date: Jan 2016
Location: Atlantic SE
Posts: 892
Drives: '10 K23 ST 7AT
Rep Power: 3376
Tractionless has a reputation beyond reputeTractionless has a reputation beyond reputeTractionless has a reputation beyond reputeTractionless has a reputation beyond reputeTractionless has a reputation beyond reputeTractionless has a reputation beyond reputeTractionless has a reputation beyond reputeTractionless has a reputation beyond reputeTractionless has a reputation beyond reputeTractionless has a reputation beyond reputeTractionless has a reputation beyond repute
Default

Mine stopped blinking after replacing the brake pedal switch (7AT) as mentioned above.
SG4247 likes this.
__________________
Toys Not Tots
Tractionless is offline   Reply With Quote
Old 05-10-2020, 05:02 PM   #37 (permalink)
Base Member
 
Gungrave's Avatar
 
Join Date: Jul 2010
Location: Brandon, FL
Posts: 129
Drives: 2010 370Z
Rep Power: 1161
Gungrave has a reputation beyond reputeGungrave has a reputation beyond reputeGungrave has a reputation beyond reputeGungrave has a reputation beyond reputeGungrave has a reputation beyond reputeGungrave has a reputation beyond reputeGungrave has a reputation beyond reputeGungrave has a reputation beyond reputeGungrave has a reputation beyond reputeGungrave has a reputation beyond reputeGungrave has a reputation beyond repute
Default

Quote:
Originally Posted by Tractionless View Post
Mine stopped blinking after replacing the brake pedal switch (7AT) as mentioned above.
Do you remember the part number for the switch?
Gungrave is offline   Reply With Quote
Old 05-10-2020, 09:25 PM   #38 (permalink)
Base Member
 
Lunar-Eclipse's Avatar
 
Join Date: May 2011
Location: Florida
Posts: 125
Drives: '10 40th Anniversary
Rep Power: 11
Lunar-Eclipse is on a distinguished road
Default

Damn that was in 2015? My Z's getting old.
But I'm happy to report that I have not seen a blinking cruise control light since replacing the switch.

This looks about right. But of course I suggest you stick your phone above the pedal in your car and take a picture to get the part number.
https://www.z1motorsports.com/switch...l-p-10344.html
Lunar-Eclipse is offline   Reply With Quote
Old 06-07-2020, 11:09 AM   #39 (permalink)
Base Member
 
Gungrave's Avatar
 
Join Date: Jul 2010
Location: Brandon, FL
Posts: 129
Drives: 2010 370Z
Rep Power: 1161
Gungrave has a reputation beyond reputeGungrave has a reputation beyond reputeGungrave has a reputation beyond reputeGungrave has a reputation beyond reputeGungrave has a reputation beyond reputeGungrave has a reputation beyond reputeGungrave has a reputation beyond reputeGungrave has a reputation beyond reputeGungrave has a reputation beyond reputeGungrave has a reputation beyond reputeGungrave has a reputation beyond repute
Default

So just a heads up for anyone else that has this problem and ends up looking for the switches. Apparently there's actually four different switches total. Two on the brake and two on the clutch. My guess in my case it's the ASCD, but just to be on the safe side; I ordered all four. These are the switches:

25300-62J0E - ASCD switch (one goes on the clutch & one goes on the brake so 2 total)
25320-JN00A - Stop light switch (goes on the brake for stop light)
25325-D400E - Clutch pedal position (goes on the clutch)
Gungrave is offline   Reply With Quote
Old 06-07-2020, 01:28 PM   #40 (permalink)
Base Member
 
Join Date: Apr 2020
Location: Space Coast, Florida
Posts: 2
Drives: 2014 370Z 6 speed
Rep Power: 2
cman227 is on a distinguished road
Default

This is now happening on my 2014 Z with 68K miles on it. Starts blinking, shut the engine off and restart and it goes away.
cman227 is offline   Reply With Quote
Old 06-10-2020, 07:57 PM   #41 (permalink)
Track Member
 
Tractionless's Avatar
 
Join Date: Jan 2016
Location: Atlantic SE
Posts: 892
Drives: '10 K23 ST 7AT
Rep Power: 3376
Tractionless has a reputation beyond reputeTractionless has a reputation beyond reputeTractionless has a reputation beyond reputeTractionless has a reputation beyond reputeTractionless has a reputation beyond reputeTractionless has a reputation beyond reputeTractionless has a reputation beyond reputeTractionless has a reputation beyond reputeTractionless has a reputation beyond reputeTractionless has a reputation beyond reputeTractionless has a reputation beyond repute
Default

Quote:
Originally Posted by gungrave View Post
do you remember the part number for the switch?
25320-jn00a
__________________
Toys Not Tots
Tractionless is offline   Reply With Quote
Old 07-19-2020, 12:37 PM   #42 (permalink)
Base Member
 
Gungrave's Avatar
 
Join Date: Jul 2010
Location: Brandon, FL
Posts: 129
Drives: 2010 370Z
Rep Power: 1161
Gungrave has a reputation beyond reputeGungrave has a reputation beyond reputeGungrave has a reputation beyond reputeGungrave has a reputation beyond reputeGungrave has a reputation beyond reputeGungrave has a reputation beyond reputeGungrave has a reputation beyond reputeGungrave has a reputation beyond reputeGungrave has a reputation beyond reputeGungrave has a reputation beyond reputeGungrave has a reputation beyond repute
Default

And another heads up. I had all of the switches replaced, considering I didn't want to have to get a different one changed later. And it looks like this solved the problem. I had it done a few weeks ago and so far the light hasn't blinked again. The car is also running smoother when I switch gears and doesn't feel like it wants to stall from a stop.
Tractionless likes this.
Gungrave is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
90 mph max cruise control? Santent Nissan 370Z General Discussions 30 02-14-2021 07:56 PM
Cruise control not working. mrarroyo Engine & Drivetrain 23 04-17-2014 01:29 PM
what can kill the cruise control? cossie1600 Engine & Drivetrain 14 03-24-2013 03:37 AM
Cruise Control Trebor3 Nissan 370Z General Discussions 13 04-21-2011 07:26 PM
Cruise control? rambunctious Exterior & Interior 3 03-22-2011 07:23 PM


All times are GMT -5. The time now is 10:15 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 PL2