Nissan 370Z Forum  

gas cap and cel(SES) code

ok guys some back story when i first purchase the car and put gas on it after emptying the gas the dealership put(they put shell which i dont like) my

Go Back   Nissan 370Z Forum > Nissan 370Z Tech Area > Engine & Drivetrain


Reply
 
LinkBack Thread Tools Display Modes
Old 06-25-2009, 11:34 PM   #1 (permalink)
Track Member
 
tru_Asiatik's Avatar
 
Join Date: Feb 2009
Location: so cal
Posts: 793
Drives: 2009 370Z 6MT
Rep Power: 270
tru_Asiatik has a reputation beyond reputetru_Asiatik has a reputation beyond reputetru_Asiatik has a reputation beyond reputetru_Asiatik has a reputation beyond reputetru_Asiatik has a reputation beyond reputetru_Asiatik has a reputation beyond reputetru_Asiatik has a reputation beyond reputetru_Asiatik has a reputation beyond reputetru_Asiatik has a reputation beyond reputetru_Asiatik has a reputation beyond reputetru_Asiatik has a reputation beyond repute
Default gas cap and cel(SES) code

ok guys some back story when i first purchase the car and put gas on it after emptying the gas the dealership put(they put shell which i dont like)
my SES light came on after driving 70 miles
look at the manual and it mentioned could be a loose gas cap i didnt think nothing of it
disconnected the bat to reset the ses

now fast forward to when i got my hfc and exhaust installed went home put gas again the light came on again
so i had the guys from amplified check it this time
code for small evap leak P0456 showed
again futher reserch indicated could be a loose or bad gas cap
the ses was removed using a odb scanner this time
again i didnt think any of it

now 2000 miles later after putting gas again light came on
so now im taking it to the dealer

now to the question(i dont want to go uninformed when i face the dealer)

i was cleaning my car and cleaning the fuel tank i notice that it does not take any effort at all to twist the gas cap off i mean literally the slightest twist the gas cap comes off right away(no matter how many times i "Click" it when i close it)
it just comes off

is this normal??

thank you in advance

ps im aware of the TSB for this code so im printing it out as well
__________________

Stillen G3 CAI*Stillen CBE*Berk's HFC*Eibach Prokit*Hotchkis Sways*ichiba 15/20mm spacers*? Oil cooler*Stillen Pulley*Stillen Headers
tru_Asiatik is offline   Reply With Quote
Old 06-26-2009, 01:40 AM   #2 (permalink)
Base Member
 
Join Date: Jan 2009
Location: SW FL
Posts: 43
Drives: 09 370Z BrSi 6mt
Rep Power: 257
rench has a reputation beyond reputerench has a reputation beyond reputerench has a reputation beyond reputerench has a reputation beyond reputerench has a reputation beyond reputerench has a reputation beyond reputerench has a reputation beyond reputerench has a reputation beyond reputerench has a reputation beyond reputerench has a reputation beyond reputerench has a reputation beyond repute
Default

I had the same issue... I told the dealer I had recently put gas in it (light came on 2 days later, I don't drive it a ton...), but I'm in the habit of overclicking the cap when tightening it just to be sure... I ended up gettin a new gas cap and so far so good.
rench is offline   Reply With Quote
Old 07-09-2009, 02:06 AM   #3 (permalink)
Base Member
 
Join Date: May 2009
Location: Hawaii
Posts: 36
Drives: '09 Black Z 6MT
Rep Power: 16
Lost is on a distinguished road
Default

I recently had the same problem, though it was nowhere near when I got gas.

In any case, the service dept told me it had to click three times to properly seal.
Lost is offline   Reply With Quote
Old 07-09-2009, 02:38 AM   #4 (permalink)
Enthusiast Member
 
Phimosis's Avatar
 
Join Date: May 2009
Location: Oildale, CA
Posts: 412
Drives: 2013 911 4S
Rep Power: 416
Phimosis has a reputation beyond reputePhimosis has a reputation beyond reputePhimosis has a reputation beyond reputePhimosis has a reputation beyond reputePhimosis has a reputation beyond reputePhimosis has a reputation beyond reputePhimosis has a reputation beyond reputePhimosis has a reputation beyond reputePhimosis has a reputation beyond reputePhimosis has a reputation beyond reputePhimosis has a reputation beyond repute
Default

I'm starting to think the gas cap thing is bogus. It is evaporative leak. It's just too sensitive. I have headers, hfc's, G3 intakes, etc. I drive it all the time.... never a CEL light. I park it for 3 weeks to get my wheels powdercoated and pinstriped. As soon as I fire it up, it throws an evaporative leak code. I was at 1/2 tank of gas, so it never thought the gas cap wasn't tight enough for the first half of that tank. Then it bleeds down, or whatever it is that happens after 3 weeks of 100 degree days and 70 degree nights and when I fire it up, it freaks out.

PS I went straight to the dealer. It didn't phase them, like this is normal to them. They unplugged my battery (cause I lost my radio settings) an within 30 minutes said, "OK, Fixed for free."

Last edited by Phimosis; 07-09-2009 at 02:41 AM.
Phimosis is offline   Reply With Quote
Old 07-09-2009, 06:20 AM   #5 (permalink)
Base Member
 
Join Date: May 2009
Location: Hawaii
Posts: 36
Drives: '09 Black Z 6MT
Rep Power: 16
Lost is on a distinguished road
Default

Quote:
PS I went straight to the dealer. It didn't phase them, like this is normal to them. They unplugged my battery (cause I lost my radio settings) an within 30 minutes said, "OK, Fixed for free."
Wow, thats kinda crappy. It seemed like a completely regular thing at my dealership too, but they went ahead and did all the tests and everything to be sure it wasn't a leak in the system.

I agree that it is a bit bogus. I've filled up my tank 3 times now tightening it the exact same way and my light came on at half a tank like 2 weeks after I got gas. But the problem was me not tightening the gas cap... yeah okay.
Lost is offline   Reply With Quote
Old 07-09-2009, 10:59 AM   #6 (permalink)
A True Z Fanatic
 
xiven's Avatar
 
Join Date: Jun 2009
Location: Atlanta
Age: 43
Posts: 4,128
Drives: Cookie Monster
Rep Power: 294
xiven has a reputation beyond reputexiven has a reputation beyond reputexiven has a reputation beyond reputexiven has a reputation beyond reputexiven has a reputation beyond reputexiven has a reputation beyond reputexiven has a reputation beyond reputexiven has a reputation beyond reputexiven has a reputation beyond reputexiven has a reputation beyond reputexiven has a reputation beyond repute
Default

it is normal. same thing happened in my car. it went away in a few days.
xiven is offline   Reply With Quote
Old 07-09-2009, 11:37 AM   #7 (permalink)
A True Z Fanatic
 
Modshack's Avatar
 
Join Date: Mar 2009
Location: Greenville NC
Posts: 2,883
Drives: 370Z Sport
Rep Power: 976
Modshack has a reputation beyond reputeModshack has a reputation beyond reputeModshack has a reputation beyond reputeModshack has a reputation beyond reputeModshack has a reputation beyond reputeModshack has a reputation beyond reputeModshack has a reputation beyond reputeModshack has a reputation beyond reputeModshack has a reputation beyond reputeModshack has a reputation beyond reputeModshack has a reputation beyond repute
Default

This does not sound like rocket science...Get a new Gas cap.
__________________

Steal my car! (SOLD)...Now Porsche Cayman S
Oil Cooler DIY: Here!
Modshack is offline   Reply With Quote
Old 07-09-2009, 11:38 AM   #8 (permalink)
A True Z Fanatic
 
tooohip's Avatar
 
Join Date: May 2009
Location: Columbia, MD
Posts: 1,626
Drives: 09 370z CY To/Sp
Rep Power: 270
tooohip has a reputation beyond reputetooohip has a reputation beyond reputetooohip has a reputation beyond reputetooohip has a reputation beyond reputetooohip has a reputation beyond reputetooohip has a reputation beyond reputetooohip has a reputation beyond reputetooohip has a reputation beyond reputetooohip has a reputation beyond reputetooohip has a reputation beyond reputetooohip has a reputation beyond repute
Default

Yep, same here. The cap clicks but 50% of the time, it will come back off with a tap. If you check it by twisting to the left just so slightly and it comes off, push down, and twist to the right again until it clicks. It seems it needs a few twists to get it just right. It sure seems odd to me, but after going through this each time I fill up, no more SES lights. ;-)
__________________
Lance
KW Variant 3 Coilovers | Stillen Sways | Stillen Gen III Intake | AAM HFC | AAM True Dual CBE | AAM Comp Oil Cooler | Hawk HPS Pads | Volk TE-37 | Hoser Keg Tap
tooohip is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
color/paint code for OEM wheels? spitfire9200 Wheels & Tires 13 06-24-2009 10:59 AM


All times are GMT -5. The time now is 10:20 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 PL2